UBUNTU 16.04 Kernel module CIFS 4.9.40

OS Ubuntu 16.04, Kernel 4.9.40 (20171025)

root@v2001:~# modprobe CIFS
-> modprobe: FATAL: Module CIFS not found in directory /lib/modules/4.9.40

root@v2001:~# apt-get install --reinstall linux-image-$(uname -r)
-> E: Unable to locate package linux-image-4.9.40

root@v2001:~# module-assistant list
-> lists several but doesn’t find any modules

What I’m trying to achieve is to get CIFS working but for as long as the relevant kernel module is missing I do get the response:
-> mount error: cifs filesystem not supported by the system

I wouldn’t want to start over again from scratch and compiling -> installing smbclient or cifs-utils doesn’t solve the problem either.

Qualified help would be much apreshiated.

Please try V180531 with CIFS enabled.

Thanks.

Yes, obviously that’s the only way, starting over from scratch and hope that this doesn’t miss any basic funktion.
It’s not what I was looking for but anyway, many thanks for your advise.

The image you’ve mentioned has VIM1 in it’s name, so I’ve used:
VIM2_Ubuntu-server-xenial_Linux-4.9_arm64_EMMC_2018-07-12.7z
but that image is doesn’t have CIFS either, different modules are missing
Isn’t there any images that really works?

CIFS is built in kernel, not built as module, so you don’t need to modprobe XXX.

Can you tell me what you want to do? And your steps? I tried V180531, and I can mount successfully.

khadas@Khadas:~$ sudo mount -t cifs -o username=XXX,password=XXX //192.168.XX.XX/wesion  /mnt

Thanks.

I’ve tried all Ubuntu images that I could find.
Summary: All 4.x Images/Updates miss some function that I need. Mostly CIFS in general or version of CIFS 2 or 3, others have no ZRAM module.
I’m using now kernel 3.14.29 which seems to have all required modules but crashes. I assume there are heating problems…
Furthermore, the LAN-, USB-, SDCard-speed is to slow for my purposes.
I wanted to use this device as an NGINX webserver with POSTGRESQL, PHP7.2 and NEXTCLOUD accessing my files on my NAS and I’m close to give it up.

V180531 4.9 kernel CIFS and ZRAM are all enabled.

VIM1 ethernet is 100Mbps, VIM2 is 1000Mbps.