Trying to update Android on VIM3...VIM3 now dead

Tonight I tried to update my VIM3 to the latest Android, I used the burn tool to create a SD card image with no problem but when I tried to get into upgrade using TST Mode I got a update screen with many options including Update From EXT which I clicked on and it took me to a screen which had multiple lines of something like ‘can’t find SD’ so I tried booting into upgrade mode using MRegister Mode. When I did this the Red LED came on bright and stayed on so I tried to reboot and the VIM3 is completely dead…nothing will bring it back.

Is it fried? Is there a special reboot or repair available?

Thanks for any replies.

hi ,no, you need to detect the board, run USBBurningTool, connect vim, press the middle button three times quickly, you will see the connection, you can flash

Red light ? means insufficient power caused it to crash…
try to use a USB powered HUB or use a USB3.0 port…

Thanks for replying. I was using a 12volt 2 amp supply when the board went down and I measured the supply with my DMM and it is outputting exactly as specified. I just now tried a USB-C cable to power the VIM3 but no signs of life at all from it.

you are all right, you need to restore the board, I wrote above as

apparently it was a failed attempt

have you tried booting into Krescue?

“you are all right, you need to restore the board, I wrote above as”

Thanks for your replies Vlad. I tried your suggestion but no signs of life, no LED’s at all on power up. It seems like the board is not getting power but I know it is. I would try Krescue but I can not get the board to run at all.

It’s past 1AM here and I’m going to hit the sack and tackle the problem with a fresh head in the morning.

1 Like

then it is clear, in the morning everything will be fine with your vim, good night buddy! these things need to be done with a fresh mind!

try a different cable and power supply

I went out and bought a new 12volt power supply and USB-C cable but the VIM3 remains dead…no LEDS lighting. I tried pressing the reset button in case this would bring it back to life but no luck with that either. I don’t know enough about electronics to really troubleshoot or repair the SBC so I am thinking of returning it to KHADAS for repair…

wait, is the LED showing something or not at all?

press the middle button three times quickly, will the LED show something?!

No LED at all. I have tried pushing the middle button three times and nothing…absolutely no signs of life. I am going to try returning it to KHADAS for repair.

@Donanon Have you not tried connecting to a computer ?
we had a similar case which was solved by flashing a new image to the eMMC flash,