Trying to enable X11

I’ve got Ubuntu 24.04 installed on the EMMC and everything was going dandy until I tried to enable X11 (rather than Wayland).

I’ve tried both methods
1/ editing the file to make wayland=false
2/ the file change VIM1S X11 Fixup [Khadas Docs]

With both methods I log in with X11 and get a black screen. If I do CTRL+ALT+F2 I go back to the Ubuntu login screen.

Hello @ronnietucker

@Electr1 will help you later.

1 Like

@ronnietucker I was able to replicate the document instructions and x11 desktop did work after a brief period of time.

Note, it will be quite slow as the desktop is rendered on the CPU. Wayland is the preferred compositor as it’s GPU accelerated.

I couldn’t get it to work for the life of me.

I did the instructions, and now when I try and log in to X11 it shows a black screen.

I only wanted X11 to try and get some sort of remote desktop working. The ‘enable’ feature in Ubuntu settings is broken (doesn’t display the on/off toggle). TeamViewer has a fail on it’s GUI (visible in terminal) and DWservice is the one that requires X11. Anydesk doesn’t do an ARM64 version.

I just wanted a remote desktop to work! Oh well… :smiley:

@ronnietucker you didn’t mention you wanted a remote desktop. You actually can use any generic VNC viewer and the build in screen sharing feature of the gnome desktop. I will share a simple guide for you to follow.


I tried the Ubuntu remote desktop feature.

When I go into Settings > Remote Desktop I get a blank panel. No on/off toggle.

You would be better off going back to 20.04 that is still running x11.

Trying to run wayland remotely is a pain. It will not function like the x11 remote you are talking about, you can launch it on the target via ssh, however, it is flaky. It depends on the console you are using and how the environment variables are passed. Way too much cloak and dagger nonsense. All the good stuff from wayland was wiped out by the lack of running remote and many other little issues.

If you are not using any of the ocp of the target then just run gui on the host. When its ready compile it on the target and then test.

For getting Settings > Remote Desktop to work, you have to install gnome-remote-desktop package. Its not installed in the image. Just run sudo apt-get install gnome-remote-desktop, then close and reopen the settings application and you should be good to proceed with further configuration