Tone1 w/GPIO + VIM3 - Won't Boot

I wanted to see if anyone has encountered this problem.

I have a Tone1 VIM board with the GPIO that’s been working well with my VIM3 in Batocera and other platforms. However, this morning I accidentally plugged the USB-C cable that powers my VIM3 into the Tone1 USB-C port. I tried turning it on and of course it wouldn’t start. After I realized my mistake, I put the USB-C cord into the right port and VIM3 still wouldn’t boot.

To troubleshoot, I pulled off the Tone board and the VIM3 booted fine by itself. I connected the tone board via USB to my win 10 computer and it also worked fine. Finally, I connected the tone board via GPIO to another VIM3 but it won’t boot on that one either.

I am wondering if I fried my Tone board somehow. Any thoughts?

The behavior I see when it won’t boot is that I get solid white LEDS on the VIM3 and Tone board. It activates the HDMI signal to the display, but then the display says no signal and turns off. The LED lights stay solid indefinitely.


Update

I erased the EMMCs and reflashed both of my VIM3s and everything works again as expected.