Tone Board not detected on reboot (Armbian)


#1

I have strange problem. Any advice?
OS - balbes150’s Armbian (debian, server, kernel 3.14.29)
VIM Pro

When Tone Board is connected to the VIM trough USB cable, everything works normal. But when trough GPIO, it is not detected after reboot (shutdown -r now) or even after power on if was executed shutdown command first. If i remove power cable and put it again - the Tone Board appears again.


#2

Hi, Stefan:
Here we will confirm first then update you.

@Ben007 Maybe it’s power on/off logic cause this?


#3

Any new information?


#4

on my home built (using fenix scripts) ubuntu xenial w/ kernel 4.9.40 :
I plug the toneboard (generic model) on the gpio 40 pins socket,
then I connect the usb-c cable from the VIM1 pro to my laptops’ usb-A port,
I use minicom and a console serial USB cable to see the boot message,
I log in , then…

aplay -D plughw:CARD=x20,DEV=0 police_s.wav
Playing WAVE 'police_s.wav' : Unsigned 8 bit, Rate 22000 Hz, Mono

and music gets out of the RCA socket of the toneboard
then, I do
sync; sudo reboot

and again, the toneboard just works once ubuntu is rebooted

If this can help balbes150 to diagnose what happens with his Armbian+kernel 3.14


#5

When you connect Tone Board with 40 PIN GPIO,it didnot need connect USB-C power cable.
Actually,if you plug USB-C with PC and the same time connect tone Board with VIMs,and tone board will swtich to PC sound card.


#6

Seriously? Where you see PC in my original post?


#8

@Ben007b check again and do response.


#9

Hi Stefan, can you confirm GPIO and power cable(USB-C?)connect tone board at the same time?


#10

It is only GPIO connected or only USB-c. Never both together!


#11

Guys is this problem exist only with my Tone Board (sample one)?
No meter of the OS and how it is connected (USB or pinout), Tone Board despairing on reboot. And to get it back, i need to disconnect it, boot the device without it, shutdown the device, connect it again and voila … until next reboot.
We had the same issue with our own XMOS and the problem was to do power cycle inside the xmos firmware to clear the previous state and to be able to report himself on reboot again.


#12

Checked the Generic version of the sound card (connect the USB cable to the VIM), the last version Armbian kernel 4.18, it works without problems. When you turn off \ restart VIM sound card automatically activated and works without manual manipulation.

Perhaps the reason is that you have, when connected to the 40-pin connector on the USB contacts (through which the Board is connected to VIM) remains powered. If I’m when I connected the fan to the contacts 5V 40-pin, there is always power after the primary power.


#13

Thanks balbes150, but my issue exist even I connect the TB to nanopi trough usb cable for example or to my Nvidia shield as well. I have order new Tone Board and will test with it because my existing is a preproduction sample.
I hope everything will be okay, so finally I will able to push TB to BG market :slight_smile:


#14

Hi Stefan:
Did you mean that you have a similar problem on other XMOS device right?


#15

No. We had in the beginning only. And the problem was similar but not exactly the same. I suppose the problem is related to my particular tone board and I expect not to have it with the new one :slight_smile:


#16

Just confirmed with @Ben007, your TB should be same with final revision.

Can you specify more details on this:

  • VIM1 or VIM2?
  • Power Adapter Spec
  • OS ROM

And if possiable, take a simple video on this, we will confirm here and update you.

Good day!


#17

It happens with VIM1 and VIM2 no meter is connected trough GPIO or USB cable. PSU is Khadas original. OS I have tested is Volumio, Libreelec, Coreelec, Armbian

I have tested with NanoPI (armbian and Volumio) and Shield (Android TV).

Video will show you nothing more but if connected first time everything is normal. On reboot TB disappear.

Thanks for your support but don’t worry. I will check the situation when my new TB arrive and will update you :slight_smile: