Tone Board no longer outputs any audio

My TB has stopped outputting any audio. I went on a trip for a few weeks and took my computer with me but left my TB at home. When I came back I found that the TB no longer outputs audio.
It doesn’t work in Windows or Linux (Arch), but did before I left.

Before this it was working for a few months without installing any drivers or touching firmware. I’ve tried reinstalling firmware and installing the Thesycon drivers to no avail. I’ve also tested the TB on two other computers, and it doesn’t work when connected to those either. I tested my Amp and it works fine, it’s not the issue.

Any help would be appreciated. Thanks!

Hi, this is probably worth paying attention to, what could have happened during this time.
Is the LED lit on the TB?

Yep, the LED lights up and my system detects the device as Khadas Tone Control. With the theyscon drivers it gets detected as an xmos device. Nobody touched the device or even went into the room it’s in when I was gone. I would suspect windows updates or driver issues to be the culprit if not for the fact that it also stopped working in Linux.

Perhaps it is worth checking the device on the sound output, what do you have there next according to the scheme …?

Do you mean here?


No, I mean after withdrawal from TB

Sorry, I’m not sure I follow. Do you mean to check if the computer outputs sound without the TB? It does (speakers and headphones are both able to output sound from this device using the onboard dac and amp).

I don’t know if it will be helpful or not, but here is some driver info from the device manager when the device is plugged in. It seems like there could be driver problems, but I still find it odd to have concurrent issues in multiple operating systems and computers.

First, try to fix the problem with the driver and see

OK, windows was unable to fix the driver automatically but I reinstalled the Thesycon driver v224 and this is what my device manager looks like. Windows reports that the device is working properly but still no audio. In the device events it also still lists that the device was not migrated and gives status 0xC0000719, though I’m not sure what that means.

Did you reboot all your devices after that?

By the way, connect better via usb 3.0 and directly to the motherboard of your PC

I tried rebooting but still nothing.
It’s connected to a usb 3.1 port on my motherboard; I think the TB might just be a USB 2.0 device which is causing it to show up like that but I’m not positive.

Hello, Do you have anything with SPDIF output? The reason I ask, you could use it to test the TB for function. If you have SPDIF coaxial output, connect the output to the TB’s SPDIF input, check analog outputs for sound. Should have something… For SPDIF test, power TB with other than PC ports.
Also, I may have missed it, but try another USB cable if available.

1 Like

I have a blue ray player with SPDIF. Just a normal RCA cable will work for connecting them, correct? I’ll give it a try later. As for the USB cable, I did try that but unfortunately it didn’t fix the issue.

1 Like

Or you can check the sound from TV to TB via usb cable

Yes, standard RCA patch cable, as long as your player is not exclusively optical SPDIF.

Hi @sneed,
Does your issues got resloved?

Just let us know if the problem still there and we will try our best to figure it out.

Stay safe & good day!