Tone board 1 + Windows 11 - powers on only from USB A, not USB C port


I recently got a new high-end laptop and the Tone Board seems not to power on by neither of the two USB C ports of the new laptop (Windows 11).
The Tone Board does power on from the USB A port (even though it sometimes disconnect unexpectedly - something I would not experience with my old Windows 10 laptop). But in any case, I need that USB A port for an other periphery, so I need the Tone Board to work with one of the USB C ports.

I have all the latest Tone Board drivers installed and I have tried tweaking the USB power options in Windows, so that the USB ports are not allowed to be powered down by the system for battery-saving purposes. No difference.

I have tried to have the laptop plugged into the mains or on battery, no difference.

I have tried different USB-C to USB-C cables (all high quality) but no difference.
The same cables on the same USB-C ports power other peripheries without problems (such as my Samsung smartphone).

What can be done to fix this?

Thank you for any input!