Support of armv8 in Android image VIM3?

I loaded to my VIM3, it worked well.

But when I tried to communicate with it by using adb command, I figured that through
“adb shell ‘uname -r’”

It seem that it only supports “armv7l”?

But I would like to run a cross-compiled C++ executable of armv8 and hence the error “not executable: 64-bit ELF file” is persistence. I tested with 32-bit executable, it worked well on the VIM3 board.

Could you please advise if I source the wrong image or there are something that I missed., @jasonl

As VIM3 has ARM cortex A53 and A73, I always assumed it supports armv8. So does it just mean the VIM “official” image does not support that?

Many thanks!

the android pie image has amlogic’s SDK which forces 32bit userspace
so only 32bit application will run, try the newer AOSP image, I believe it enforces the 64bit userspace

Many thanks, but I do want to run Android 9, not Android 12 on the board, so I guess the AOSP solution is not applicable

@cosmocidee now VIM3 android 9 only support armv7 32bit

Is it possible to port this version of Android 12 AOSP to run on the Vim2?