Steamcmd on Khadas VIM

I’ve recently brought a VIM to use it as a small Game Server for Friends. But i cant get Steamcmd working, whenever i try to follow other Tutorials (which are mostly for a raspberry), i get a prompt which want to uninstall everything in order to get the i386 drivers working.
My question now is: did anybody managed to get steam or the steamcmd running on the arm64 architecture? And if so wouldn’t mind to give me a little tutorial?
To me: i just started learning command line linux and don’t know very much yet. So please be noob friendly :slight_smile:

Thank you very much!

Edit: Im not sure where this topic belongs, so if its on the false board, im sorry

Hi, Godless:
I’m not familar with Steemcmd, hope some other folks in our community can help you out. I think you can describe your questions/problems with more details, I think following info would be helpful:

  • The instrucion link you tried to install
  • The steps you did and the problems you met


Hey Gouwa,
i used this: in combination with

First was a problem with the sources.list, because the ones for the i386 were missing, so after some research i found the right repositories. So after this problem was fixed i ran “sudo apt-get install libc6:i386” and was greeted with a message saying, if you do this practically everything on this system will be deleted. (I dont have the output saved and to get it again, i would need to reinstall the i386 architecture and fix the sources errors, so i cant show it sorry =/ )

Maybe i can get wine to work and try to emulate the windows version of steamcmd. After my finals in the next weeks i´ll try that, and if it does i will let you guys know.

If in the meantime someone knows or finds an easy solution, please let me know.

So i managed to get Steamcmd and a Counter Strike : Source Server running.
Sadly i didn´t managed to get it running with qemu. I only managed to get everything working with a paid Software called “Exagear Desktop”, which cost 25 bucks. After installing it and the multiverse repository, i simply could install steamcmd and run it without any problems.

I wished i found a free way to do it, and i´m pretty sure there is one. But with this software, although its high price tag, everything works fine with little to no configuration.

Hi Im new in this forum. Help me please, Ive a Khadas version 8gb and I don´t run streaming on kodi. There are block image, and block a box, in any resolution. The connection are ok, and ethernet is the same block on kodi and in youtube. Only have two app, youtube and kodi and the box very hot after 5/10 min in on, I install the last rom ant the rom atv (by supercelerom) and are the same. Even if you install the fork of the kodi ftmc, it happens the same. I have already tried to install advanced settings and it does not improve.

Im sorry but it apppears that you wanted to create a new topic instead of replying to this one. You maybe want to create a new one.

1 Like