SSD New M2x expansion board problems

I have a vim3 pro /new heat sink/fan/new m2x expansion board.
I’m finding the ssd is not very quick especially unzipping aml_npu_sdk_6.4.3.7z which also affects the screen by flickering why ?

Is it possible to boot operating system from Kingston A2000 (SA2000M8/250G) SSD NVMe PCIe M.2 2280, 250 GB attached to new m2x extension.

Hello, Regarding the flickering, what power supply are you using? This issue is discussed in this thread.

PCIe NVME is single lane, not sure if the speed you are seeing is consistent with that.

NVMe boot is not available at the moment

Thanks for you reply
Will it be available soon?

no idea, but mainline may potentially have support in the future but no info for now…

I’m using dc 5v 3amp plug.
I’m trying to unzip aml_npu_sdk_6-4-3.7z estimated time 47 hours. it takes 7 min on usb stick!!!
this can’t be right!!!

There are patches for pcie/nvme boot on the u-boot mailing list. The intitial submission has snowballed into a more general reworking of support for the dw-pcie IP block which is used with several SoCs but it is making progress and moving forwards. I’d expect support to be in 2021.07, but should be simple to patch onto 2021.04 sometime soon.


Even I have faced exact same error. Mostly Mainline Kernel issue. I will give it another try on mainline kernel and see if I get it to work smoothly.

Thanks for the reply. As I have struggled for a week or so with a number of issues Android apps hanging etc. I tried most of the OS ubuntu focal the better. I have decided to return the machine and wait until we can boot from ssd later on in the year