SSD disconnects


my VIM3 boots and from time to time it can even mount my SSD via USB3. But it takes only minutes while writing to the SSD until it disconnects. I get an identical log message with a different USB device.

What I’ve tried:

build new Linux Debian Image 5.9-rc2, DTB and Uboot with Fenix
changed SSD (several Crucial MX and Intel)
changed cables (from SSD and power supply)
changed SSD case
changed power supply (3 different types, even one with Quick Charge)
changed USB port
switched between plain partition and lvm2
removed Wifi/BLE antenna because it was said Wifi and USB3 can’t operate together (HW issue)
erased EMMC
removed USB keyboard because of power consumption
examined HW
Any ideas left? Any help is HIGHLY appreciated!!!
BTW, I have another Vim3 that runs perfect after struggling with SSD, Ubuntu and Docker…

It feels like you have to prove expertice ti run a Vim :frowning:

Thanks in advance,

@acema This is caused by the insufficient power supply of USB3 to support the use of SSD. That can’t be solved by software.

this SSD isn’t a supported model iirc, do you have something like an Intel 660p ?
if that model doesn’t work either, your definitely struggling to provide ample power the the device as @Frank infers.

stay safe & good day.