[SOLVED] Wifi 5GHz not working on VIM3pro with Ubuntu von Khadas

Hi guys, I have VIM3pro and Wifi 5 works well on CoreElec, but does not work if I boot Ubuntu from SD card.
The 5GHz networks are simply not seen and if I try to manually connect it also not possible. May be there is anywhere a driver required to be installed in Linux?
I need higher wifi speeds as VIM3 operates for online videos and 2,4GHz net is rather loaded.
I also have a difficulty connecting BT keyboard and mouse. Ubuntu does not see any BT devices if I search and try to connect them

@koaly Which one firmware you used ? Did you have upgrade you system to leatest release ?

you can check it via this command .

$ cat /ect/fenix-release

I use * VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_SD-USB_V0.9-20200530(Latest release)

@koaly Did you have upgrade you system ?

Of course, sudo apt-get update and then upgrade in terminal

@koaly Can you provide the result of this command ?

$ cat /ect/fenix-release

I will test it and faceback here

@koaly I think @Frank meant:

$ cat /etc/fenix-release

*etc not ect

1 Like

Many thanks. I did not understand what ect mean, but whatever. Here is the result

@koaly I will test it today

many thanks. I hope to get the 5Ghz Wifi and BT working in Ubuntu. Actually, BT does not see any device while searching.

Hello @koaly

We have checked on our side, we don’t have the 5G Wi-Fi issue, it works well.
But we have the same bluetooth issus with you after system upgrade, we will fix it in next release.

For now, there is a workaround to fix the bluetooth issue for you, you can try to restart the bluetooth service manually to fix it.

$ sudo systemctl restart bluetooth-power-fixup.service

Thanks for the response. I will check BT.
What would you suggest to do do fix the 5GHz Wifi?

I do not understand why 5GHz works well in Coreelec, launched from EMMC, but nothing is seen in Ubuntu.

I have no idea yet, the 5G Wi-Fi works well on our side.

What’s the result of this command?

$ nmcli d wifi list

Only 2,4 GHz are seen by the device. koaly is my router with 3 nodes.

As I can see, VIM3 does not work in 5GHz frequency in Ubuntu. May be there is a certain low level driver or FW required for the board?

What’s the channel of the 5G Wi-Fi? Can you double check with your phone to confirm the 5G Wi-Fi exist?

This is 48’th channel and Coreelec has no problem to connect. I attach the photo from my TV with VIM3 running it. As you can see 5Ghz is connected.
And there are also screenshots from mobile phone WiFi scanner.
What could be wrong with Ubuntu?

Hi numnqq, thank you for the support. I started the VIM3 today and some packets were updated. After that it started finding 5G networks. The result also looks differnet showing the bars.

BT works well after restarting the service as advised above.
The issue is solved and I would close the topic.