[SOLVED] Problem on install kodi


#1

Hello friends

First, sorry about my bad english, I am from Brasil.

I already install Ubuntu Mate on my Khadas Vim, and I want to install Kodi.

I get this error, anybody can help me?

khadas@Khadas:/mnt/sd64$ sudo apt-get install kodi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kodi : Depends: kodi-bin (>= 2:17.3+git20170525.0741-final-0xenial) but 15.2+dfsg1-3ubuntu1.1 is to be installed
        Depends: libshairplay0 but it is not installable
        Depends: libcec4 but it is not installable
        Recommends: i965-va-driver but it is not installable or
                    libva-intel-vaapi-driver but it is not installable
E: Unable to correct problems, you have held broken packages.

#2

You can try this Debian build. It has Kodi integrated.

http://forum.khadas.com/t/armbian-kodi-ubuntu-debian-for-sd-usb-emmc/825


#3

Not working! Why?


#4

You can try to provide extra power supply for vim or change usb port on the PC:
http://docs.khadas.com/basics/ExtraPowerInput/


#5

Hello, What image are you trying to burn?


#6

Armbian, from here:

The same problem in any image from this page.


#7

What are you trying to install ? In the desktop images (MATE\XFCE) KODI is already installed and configured. To start KODI, the login screen (lightdm) choose in the upper right corner in the selection menu, what graphical environment to run. Then enter the username and password of the user you created when you set up. The system will automatically start KODI. To exit KODI, select EXIT. The system will return to the login menu.


#8

Sorry friend, you didnt understand.
The first installation (first post on topic) was Vim_Ubuntu-mate-16.04_Linux-4.9_V170605

After, I tried install Armbian (with KODI included), but I get other error in USB Burning Tool.

Now I reinstall the Vim_Ubuntu_Mate, and install Kodi.
I think is working now, I need to test.

Sorry about my bad english, and thank you by the help!