[Solved]Khadas Remote not working with LibreELEC?


#1

Model: Khadas VIM2 Pro v. 1.2
Device tree: https://sx05.eu/s912/8.2/device_trees/1Gbit_Ethernet/gxm_q200_3g.dtb
Image: LibreELEC-s912.arm-8.2-8.1.10.img.gz from here:
https://forum.libreelec.tv/thread/5848-8-1-10-libreelec-8-2-for-s912/
Running from: mSDHC-card

Khadas remote:

Hi!

Trying to get the Khadas remote (see link above) working with LibreELEC but it doesn’t work.
I can’t see anything in the LibreELEC log here:
http://sprunge.us/YJaZ

I am also trying to get my LG Magic Remote (for my LG OLED55B6V) which is called “AN-MR600” but that does not work either. I have ordered a IR-receiver and thinking about installing “LIRC” in order to map both controllers but has anybody got the Khadas Remote (and/or LG Magic Remote) working with LibreELEC?

Best Regards / TheSwede86


#2

You can try to download and check these files (download, rename and put in configuration folder on the SD card) ? I have no such control panel like in the link. I have the first version of the remote control (VIM1) with the first version of the file “remote.conf.vim”.


#3

Thanks for your reply.

When I SSH into my VIM2 I find this file:
/flash/remote.conf
which has this content:
https://pastebin.com/FcsNuDzi

Since the filesystem is “Read-Only” I had to remove the SD-card and edit it on my computer so I moved your file:


to /flash/remote.conf while saving the original as “remote.bak”

remote.conf.vim2 did not work.

I tried the file here:

That did not work either :confused:


#4

Try putting the file “remote.conf” in /storage/.config. Maybe I’m confused, but in the images Kszaq for files remote now does not work the directory /flash.


#5

Thank you for your reply, with this file (renamed as “remote.conf”):


in:
/storage/.config/
the controller works!

Power On/Off works
Up, Down, Right, Left works
Back works
The “mouse button icon” does not work
The “menu icon” does not work
Increase Sound / Decrease sound works
Home works most of the time (might depend on which menu you are in so it is Kodis “fault”)

Thank you so much :slight_smile:

Can you talk to @kszaq so he might integrate the controller support into his releases?

Update:

Just started working with my TV-controller!
I switched HDMI-cord but I believe that the controller works from boot but instantly when Kodi is started it does not start, it takes around 10-15sec before I can use it. If I press any buttons before that everything just kind of happens at once when it starts registering keypresses.