(Solved) Flashing Uefi 'killed' my oowow restore

I can flash uefi into spi no problem it run and doesnt detects my emmc on the likes of fedora and opensuse for arm.

But… now I wanted to go back into OOWOW and flashing wow via spi to sd doesnt works… tries to reboot and restart into uefi.

Used rkdev to erase both emmc and spinor and reflashed the spi from oowow it completes but the board doesnt awake stays dead one light on no fan no noise.

Ive tried to flash all 3 oowow files with the spi file none brings oowow alive only reflashing it with the uefi file does.

Ive been the whole day today trying to bring it back and… Im loosing my mind… I dont have UART idk how to do that stuff…

All I did in the beginning was this command:

wget https://github.com/edk2-porting/edk2-rk3588/releases/download/v0.9.1/$EFI
sudo dd skip=2048 seek=$((0x4000)) count=$((0x4000)) of=$DISK if=$EFI conv=fsync,notrunc

It all worked fine but now im not having access to a terminal with wifi to be able to revert it by command so… idk what else to do…

Dead… :smiling_face_with_tear:

I cant seem to get the emmc recognized on any uefi image.

@DarkevilPT did you try to extract the image from the *.gz archive ?
It seems like you are trying to flash the compressed archive to the spi flash and it must be failing.

Nope. Just renamed the file removing .gz because extracting it with winrar ends up in an empty folder. (This on Windows).
No good… just flashed … no sign of fan… no video output via hdmi its wierd.

About the uefi… the khadas docs mentions a few warnings and tips regarding some blocks that needs be reserved I dont know if thats causing the emmc not being recognized on uefi installs… any chance something is blocked from there ? Idk how to erase the emmc unless via rkdevtools which does works. But is it really? Uefi not detecting the emmc on board requires me to install uefi images under an nvme enclosure which sucks.

Maybe you need to do checksum after extracting the image ?

Problem solved… Windows print screen tool doesnt let me capture the right click button when pressed… (Sorry for the bad quality via phone camera)

So basically two problems:
1 - I didnt knew I had to extract the .gz files to run them into rkdevtools.
2 - I was using windows extract all thinking that was winrar… other than really using winrar tool to extract the file.

Once that was done right… flashing ended up with the fan spinning and I believe this fixed it.

Thank you @Electr