[SOLVED]: Edge-V: Domain: network - Problem moving resolver from NetworkManager to networkd

I was able to move to netplan on ubuntu bionic with own yaml files for eth0 and wlan0, by hiding the fenix-default.yaml file, because I use the Edge-V as an headless server and NetworkManager is used mainly in X11 environments.

I tried to completely stop, disable and mask NetworkManager with

sudo systemctl stop NetworkManager
sudo systemctl disable NetworkManager
sudo systemctl mask NetworkManager

After reboot the WiFi was not working. It works only if I unmask the NetworkManager, but I want use networkd as the netplan resolver even for WiFi.

How can I do that?

Current image uses NetworkManager to setup the Wi-Fi.

What does WiFi was not working ? Does the wlan0 node is not exist?

In my very special case I am not using NetworkManager while running in headless mode and using netplan and systemd-networkd is enough. I have a good experience with netplan using Ubuntu Core 16 since two years.

My mistake was to only mask the NetworkManager service. This is not sufficient.

I had to remove it completely with sudo apt remove --purge network-manager from the system. After a reboot WiFi was accessable over systemd-networkd :smiley:

Thx for help.

1 Like