[SOLVED] Display resolution issue in SD-loaded Ubuntu

Hi guys, I could not find an answer anywhere.
I have Ubuntu running on VIM3pro from SD card.
It works well except the limitation in the screen resolution 1920x1080, which I cannot change and which is not usable on the 4k display, because the outer borders are out of the field of view. Look at the pictures.

How would it be possible to add more screen resolution options into the Display menu in Settings?

The system software is fresh and up-to-date.

which image and kernel version is this ? please check the app drawer in the bottom left corner, there is a app called screen resolution, maybe you can set it there

also check your monitor settings to see if you can adjust to the correct resolution

1 Like

Hi, thanks for the feedback. the kernel is 4.9.241 and the image is taken from official Khadas repository from 20200530.
The app shows available resolutions, but the required 4K resolution with 16∶9 is missing: 3840x2160.
Is there a chance to add this resolution to the app or in the Ubuntu settings?

I suggest trying 2160p, if not try something lower to see if it can match your screen aspect ratio

Perfect. It works well now. Many thanks. the topic is closed

1 Like

glad it worked :slightly_smiling_face:
please mark solution and end topic

have a good day!