[Solved]Cannot found device in adb [VIM3]

Hello,

I got a vim3 basic board, connected it via usb-c port and powered on. However the devices is not showing in the adb devices list, can not be found in android studio either.

USB debugging is enabled as well as the developer mode. Perhaps I missed some steps, need some suggestions… thx

Hello, I am out of my element regarding adb, I am only casually familiar with it.
I found this thread on the VIM1, maybe it would also apply to VIM3.

1 Like

@gx_devil , the frist to connect , you need to allow the request with you display. Are monitors used?

Hello Frank,

Thanks for your reply, I connected vim3 to a monitor via HDMI cable. However no permission window showed up on the screen. Developer mode and usb-debug were enabled.

I used a single usb-c cable for power and data transmission, should I use an adapter to power vim3 and another usb cable to connect to my computer instead? Thx

Hello RDFTKV,

Thanks for your reply, I will try out the methods in the thread. :slight_smile:

@gx_devil did you try it with LAN/WiFi,This docs abuout how to use it .

2 Likes

Hello Frank,

I tried connecting to the device via LAN, its working now, thanks!