Smstools3 not working

Which version of system do you use? Khadas official images, self built images, or others?

official Ubuntu from OOWOW (22.04 v1.4)

Please describe your issue below:

I cant get smstools3 to work. I have the quectel EM06 4g module (official ad-on) (european version).
Internet works perfect. Smstools is a daemon and it looks at some folders. If you put a “sms-text” file in the map “sent”, the daemon processes it. In my case, its dropped in the map “failed” with “Fail_reason: Modem initialization failed” or “Fail_reason: Unknown” added to the “sms-text” file.
I dont have any incoming sms.
I can get a connection and send AT commands to EM06 with Minicom. (sudo minicom -D /dev/ttyUSB2). I tried sending AT commands with python to /dev/ttyUSB2 and get an error “error: Device or resource busy”.
In the smstools log i get the same error: “error: Device or resource busy”.
I have put the modem in “usbnet” mode, and in “normal” mode with minicom, no difference. (see khadas docs EM06 module)
I restarted the process as super-user, but no difference.

Any help or suggestions are welcome!
Kind regards

Post a console log of your issue below:

2023-01-22 17:23:31,2, smsd: Smsd v3.1.21 started.
2023-01-22 17:23:31,2, smsd: Running as smsd:dialout (119:20).
2023-01-22 17:23:31,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2023-01-22 17:23:31,3, GSM1: Couldn't open serial port /dev/ttyUSB2, error: Device or resource busy, waiting 30 sec.
2023-01-22 17:24:01,3, GSM1: Cannot open serial port /dev/ttyUSB2, error: Device or resource busy
2023-01-22 17:24:01,2, GSM1: Modem handler 0 terminated. PID: 4190, was started 23-01-22 17:23:31, up 0 min.
2023-01-22 17:24:01,2, smsd: Modem handler 0 (GSM1) terminated while mainprocess is still running. Exited, status 127.