Serial debug console


After unpacking my VIM1S and connecting the serial debug console, I could see the booting of the OOWOW. When it was booted everything I typed was rubish. So I couldn’t do anything.

With the help of the OOWOW hotspot I could program the linux on the emmc. When I was connected to the hotspot I could connect with putty and install linux. So my characters arrived correctly.

When the linux is booted with the serial debug console connected my keyboard characters still don’t get shown correctly.

On the picture below I typed 2 letters (2times, “k” and “l” if I am not mistaken) but I only see strange characters.

Here are the settings of the putty that I use:

I also tried to use secureCRT 9.3 but this gave me the same result.

For the communication I use the USB-RS485-PCBA from FTDI

What am I doing wrong?

Kind regards

Hello @Dieter

Please double check the hardware connection. By the way, have you tried other serial tool?

Make sure that echo is off.

Try using linux with gtkterm.

And,with windows make sure you have the correct driver installed.

Hello @numbqq

The text from the khadas I can see very clearly so the RX connection should be good. When I change the baudrate the text gets scrambled. So this should be good.

When I disconnect the TX nothing arrives on the terminal. So this should be also correct. And this is connected next to the RX connection.

I have connected also the grounds of the devices.

Have you been able to use the serial debug console with putty?

At the moment I don’t have another hardware serial tool.

@foxsquirrel thank you for your feedback.
unfortunatly I don’t have a second device to run linux on. I have installed the FTDI driver I don’t know if I need any other driver.

Any other possibilities?

Kind regards,

Yes, PuTTY works well on my side, and SecureCRT also works.

Do you use the default PuTTY configurations? Have you changed other part?

And for SecureCRT, please make sure the Emulation Terminal is Linux.

They have one that is for Win 11 assuming that is what you have. Also, you must reboot after installing that on Win.

Do you have another USB to TTL adapter to test with?
Have you tried your adapter on other boards to make sure the adapter is okay?

@numbqq @foxsquirrel


Sorry for my late response but had to find another adapter. So I tested the FTDI with a VIM1B board and this results in the same manner.

After this I tested with the CY7C65213 board and now it works. So the problem is the FTDI board.

Thank you for the quick response.