Screen Resolution (Ubuntu)


#1

I have installed ubuntu now following:

everything went well, but…

I cant see how to change the resolution of the screen, there is no way to change something in the settings.
maybe something wrong with my monitor? (LG Flatron W2452T)
to make my situation more worse, zero experience with Linux :slight_smile:

Thank you
Sorry, english is not my language


Displaying to a VGA monitor through an adapter
#2

Hello, Have a look here, under the section labeled, “Setup HDMI”.

Linux can be a challenge for new users, but you will get to know it better. Information on Linux is everywhere.

Of course, information about Linux on the Vim, can be found in these forums and Khadas Documents.

Many here will attempt to help. Don’t hesitate to ask for assistance. :slight_smile:

Cheers.


#3

Thank you for the link, i will try :wink:

I was just wondering if its only me or others also cant change the resolution. Anyway, weekend I will try a different Monitor (TV)

You right, Linux is challenging, but also a lot of fun


#4

Normally in Linux, you could change the resolution with the graphic display manager shown in your screenshot.

But with Linux on ARM devices, I have not seen the display manager work to change resolution. This is true for all ARM devices I have run Linux on, both Amlogic and Rockchip.

Like many new experiences in Linux, it is a good opportunity to learn some stuff. As you said, that is a lot of the fun. :slight_smile:

I have not attempted to change resolution on the Vim yet.


#5

I am using ubuntu from the emmc and I also cant change the screen resolution. It looks like ubuntu cant get the monitors info correctly and so does not offer different resolutions.


#6

Hello, Did you try this(from above post)?


#7

I tried the linked instructions and pasted the lines into my /etc/rc.local script

It did not help. I still got 1920 x 1080 output when hooked up to my 1280 x 800 monitor and after a few seconds the screen was a mess. This messed up screen also showed up after a few seconds when connected to a 1920 x 1080 display.

I deleted the lines and the screen is once again stable (still no 1280 x 760 support)

Any help would be appreciated!


#8

When I run “inxi -G”, I get the following:

Graphics: Card: Failed to Detect Video Card!
Display Server: X.Org 1.18.4 driver: fbdev
Resolution: 1920x1080@0.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
GLX Version: 3.0 Mesa 12.0.6

There is source for a mali-450 driver at:
https://developer.arm.com/products/software/mali-drivers/utgard-kernel

I do not know how to compile it and add it into my system


#9

Thx!

Setting the /etc/rc.local gives me a clean 1080p Ubuntu display:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

 echo 1080p60hz > /sys/class/display/mode
 fbset -fb /dev/fb0 -g 1920 1080 1920 1080 24
 fbset -fb /dev/fb1 -g 32 32 32 32 32
 echo 0 > /sys/class/graphics/fb0/free_scale
 echo 1 > /sys/class/graphics/fb0/freescale_mode
 echo 0 0 1919 1079 > /sys/class/graphics/fb0/free_scale_axis
 echo 0 0 1919 1079 > /sys/class/graphics/fb0/window_axis
 echo 0 > /sys/class/graphics/fb1/free_scale
 echo 0 > /sys/class/graphics/fb0/blank

# LED
 echo breathe > /sys/class/leds/red/trigger

 exit 0

#10

Sorry for the thread hijack.
Does anyone know the parameters for a 4k config, or if it is even possible?

Thanks