[resolved] Pb with mkinitramfs .... open /dev/fb0: No such file or directory

I am trying to create my own system by following the commands of the following link:

The problem is that I’m stuck when I created Initrd.

Indeed by launching the following command:
“sudo chroot / mnt / mkinitramfs kvimrootfs -o /boot/initrd.img $ (cat ~ / project / linux / include / config / kernel.release)”

I have the following errors:
"open / dev / fb0: No such file or directory
/etc/initramfs-tools/scripts/local-top/khadas_init.sh: 4: /etc/initramfs-tools/scripts/local-top/khadas_init.sh: can not create / sys / class / display / mode: Directory nonexistent
/etc/initramfs-tools/scripts/local-top/khadas_init.sh: 6: /etc/initramfs-tools/scripts/local-top/khadas_init.sh: can not create / sys / class / graphics / fb0 / free_scale: Directory nonexistent
/etc/initramfs-tools/scripts/local-top/khadas_init.sh: 7: /etc/initramfs-tools/scripts/local-top/khadas_init.sh: can not create / sys / class / graphics / fb0 / freescale_mode: Directory nonexistent "

I tried to create the files and directory manually, but after completion of the file update.img, I find myself with a Kvim without screen and ethernet connection.

I did several research, but nothing and done.

Thank you for all the help you can give me.

Sincerely Marc.


I continue my search since the baby to solve the problem of missing files.

  • The kvim_defconfig is ok
  • I have the modules: mali.ko and others to create

Logging in: sudo chroot / mnt / kvimrootfs, I tried to load the following modules: mali, aufs and dhd, I had a problem indicating that the file / proc / modules did not exist. After its creation, I manage to load a module (modprobe mali) but it does not appear in the list (lsmod), and I do not see an error message.

While waiting for your support, I continue my research, on the creation of the file / proc / modules.

Sincerely Marc.

I think the problem comes from the installation of the “DEBOOTSTRAP”.

Sincerely Marc.

Hi marc_059,

You want to build your own image? Maybe you can try this:

1 Like

Thank you for your help, but I tried this method and I had more problem.

On the other hand, I have advanced, it is good debootsrtap that poses problem.

In fact, when I command “sudo chroot / mnt / kvimrootfs / debootstrap / debootstrap --second-stage”, I have at first “ll / mnt / kvimroots / proc / | wc -l”, 319 files and when order is over I have more than 3 left.

I run this command under Ubuntu Kvim2, which serves me development.
I tried on another server machine (x86), but it does not have enough space on the disk to perform the operation.

Maybe that’s where all my problems come from.

Sincerely Marc.


In fact it’s normal, since I did not have to edit the directories, which is done by the following commands:

“mount -t sysfs /sys /mnt/kvimrootfs/sys
mount -t proc /proc /mnt/kvimrootfs/proc
mount --bind /dev /mnt/kvimrootfs/dev
mount -t devpts /dev/pts /mnt/kvimrootfs/dev/pts
mount --bind /tmp /mnt/kvimrootfs/tmp”

Sincerely Marc.