Remove Khadas boot logo


We want to remove the Khadas boot logo. We have tried to follow this article but not able to get it working. Can you please guide us on the same?


This worked well for changing the logo for me:

1 Like

Hi Mldevw,

I am not looking for the boot animation I want to replace Khadas boot logo at startup. I already successfully replaced boot animation and right now stuck with removing Khadas boot logo. If you have any idea about how to do that please share with me. You can check screenshot to get idea about what I am actually asking for.


hello, a person already had a similar situation, hyphop helped him with this, try to contact him

Hi Vladimir,

Thanks for the reply and I am new to this forum and don’t know how to contact someone directly for any queries. @hyphop can you please help me on this to fix the same?

Thanks in advance.

yes, so he should notice you, or in a personal you can write …
have a nice day!

@rcb13 do you want to remove the Khadas boot logo, or replace it ?
boot logo is a part of the uboot…

It seems to me that he wrote everything clearly and clearly! Pay attention ,buddy :thinking::wink:

but since, the Title of the thread was “Remove” khadas boot loader… I wasn’t sure…

they should change the title then as it is misleading…

I think everything is in order there too and you can leave everything as it is!

Hello. If you click a user’s avatar, you will see a message button.

Both will work remove or replace with our custom logo. We tried uboot as per the document but its not resolving the problem.

there isn’t anything in the document, It is TBD (, which one are you referring to ?

I think he himself would like to know how ?!

VIM1 and VIM2 have data in their respective docs, but VIM3’s docs is empty, you can ask @Numbqq and see if those same instructions apply here…

Thanks @Electr1. @numbqq can you please help me on this?

Hello @rcb13

Which image you used ?

There is a documentation about how to change boot logo for ubuntu.

Hi @numbqq
We have used android image VIM3_Pie_V190809.7z

Hello @rcb13

So you just want to remove the logo, right ?

Can you try this command in android command line ?

$ su
$ dd if=/dev/zero of=/dev/logo bs=1M count=1

Then reboot the board.

Hi @numbqq
I tried executing command that you shared but it gives following output.

kvim3:/ $ su
kvim3:/ # dd if=/dev/zero of=/dev/logo bs=1M count=1
dd: block size `1M’: illegal number
1|kvim3:/ #