Problems to upgrade Edge-V

Hi,

I have an Edge-V which is completed bricked after testing on 4k resolution with the Edge_Nougat_V190614 OS.

It is not booting anymore and I am not able to flash the mmc, neither boot from SD Card or not even enter in MASK Mode to upgrade Using a USB-C Cable (I installed the USB driver in 3 different windows versions vista, 7 and 10).

I have followed all of that steps:



I used varied USB-C cables with no success. And there is no hardware issue.

It’s really important to mention that I can not find the any input when I plug in the usb the board (by dmesg). I mean, the usb is not up.

I have no serial access.

Do you have any idea to help me?

Hi @cassiovolcan
Which USB-C port you connected to PC? Be note only the data one should be connected to PC:

Thanks!

Hi,

I’ve tried it already. As I mentioned before there is no message in the host (by dmesg) once the board is plugged in (connecting either both cables or just data one).

Try again:

  • Only with the Data USB-C cable to your USB 3.0 PC
  • Be note don’t connect the Power USB-C

Thanks!

1 Like

I tried it again. The USB driver is not up.

https://mega.nz/#!H7JCFYpL!iT_jo_6KZ6veYjRNCXoPLlBMDMvCyZ9Y6Iv_2kJNpgs
I just applied for the latest driver(DriverAssitant_v4.8) from Rockchip. You can try it.

Hi,

I also tried this one you just sent. No success.

Actually I was able to upgrade before, and after it stops working (brick) I can’t.

I think the kernel is bricked so can’t put the usb driver up.

Any idea?

Your board should be V11 version. As shown in the figure.
image

MRegister Mode(Maskrom Mode)

  1. Connect to PC with USB-C port.
  2. Use a tweezer to short-circuit the two pads of M register, then without releasing…
  3. Short press the Reset key and release it to boot into Upgrade Mode (Maskrom Mode).
  • or
  1. Use a tweezer to short-circuit the two pads of M register, then without releasing…
  2. Connect to PC with USB-C port.
  • or
  1. Long press the Function key without releasing it.
  2. Connect to PC with USB-C port.

Note:
image

If not, it may be the problem of data line. It is suggested to change it better. Or better use the interface data line shown below.

I also tried all of this. There is no rockusb device either or unknown device.

I tried 3 different data cables and 3 different pcs.

there is no such option after plugging it in.

Maybe there’s something wrong with the board. Will the light turn on when the power is on directly?

Yes.

It does not look like is a hardware issue.

Better send the board back to us for repair.