POE LAN network interface not detected - M2X extension board + VIM3L

Hello everyone,
I bought a VIM3L (running Ubuntu 18.04.3) and a M2X extension board to have this exact setup:

The problem is in the M2X extension board.
In the product description I’m reading

“VIM3 can simultaneously use both Ethernet ports (1Gbit & 100Mbit)”

But I cannot find the M2X network interface, I only have eth0.
I even enabled it in /sys/class/usb_pcie_switch/mode

echo 1 > /sys/class/usb_pcie_switch/mode

And it did the trick in making it recognize the NVME SSD but not the POE LAN network interface.

What do I need to do to enable It?

Thank you in Advance for your help
Marco

1 Like

Does anybody know how to solve that issue?
I have exactly the same problem.

I also tried to enable M2X using that instruction - How to enable M2X ETH through overlays | Khadas Documentation

But I still doesn’t have the second eth.

I’m using Debian (installed via KRescure, linux 5.9)

Hello, Welcome aboard. At the risk of stating the obvious, have you set PCIe/USB to PCIe? See here.

Seems like I have no mcu folder (official Debian release, installed using KRescure)
I also tried to use Ubuntu minimal (also installed using KRescure), and it works fine for ubuntu.

What can I do, if I want to use Debian?

Hello, you need to ask Hyphop, mark it in your message, do not forget the “@” symbol in front of its nickname

1 Like

@hyphop can you help with MCU?

I used KRescure to burn Debian image (VIM3, Linux 5.9). And there is no mcu folder in /sys/class folder.

Is it expected behavior? Is there any other way to switch between PCIe / USB modes?

u can use krescue for switch kbi modes
or try to use this scripts khadas-utils/kbi at master · hyphop/khadas-utils · GitHub directly in your system

So, now I switched port mode to the PCIe (using KRescue), but still have no network on Debian.

I have only one ethernet interface (which is not from the M2X board). Does anybody have any ideas on how to fix that?

UPD: Also, I have checked Ubuntu with 5.10 kernel (built using Fenix script). The same problem on that build - the MCU folder does not exist and the M2X ethernet is not working.

So, do anybody knows how can I fix the issue?

Now I’m running Ubuntu minimal with 5.10 kernel (built using fenix script), PCIe is enabled via KRescue, M2X ETH is enabled using overlays Device Tree Overlays. But there is still no second eth interface visible.