PL2303 Setup Serial Debugging Tool

Hi all

My first days experimenting with VIM2 …

I manage to, say, armbian (but also gentoo), boot from external SD.

So I next connect USB-serial adapter to the correct pins.

And I see in dmesg (on linux host where USB is plugged in):

[727189.922489] usbcore: registered new interface driver pl2303
[727189.922500] usbserial: USB Serial support registered for pl2303
[727206.064954] usb 3-1: new full-speed USB device number 5 using ohci-pci
[727206.326042] usb 3-1: New USB device found, idVendor=067b, idProduct=2303
[727206.326045] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[727206.326046] usb 3-1: Product: USB-Serial Controller
[727206.326047] usb 3-1: Manufacturer: Prolific Technology Inc.
[727206.328091] pl2303 3-1:1.0: pl2303 converter detected
[727206.350116] usb 3-1: pl2303 converter now attached to ttyUSB0

Also: pl2303 kernel module is loaded

# lsmod | grep pl2303
pl2303                 20480  0
usbserial              32768  2 usb_serial_simple,pl2303
usbcore               212992  13 usbmouse,usbhid,snd_usb_audio,usb_storage,ehci_hcd,ohci_pci,usbkbd,usbserial,snd_usbmidi_lib,btusb,ohci_hcd,pl2303,ehci_pci

And USB lists it as well

# lsusb | grep 067b:2303
Bus 003 Device 005: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

But with given ~/.kermrc and adjusted permissions kermit does gets off
but did not really connect or show any prompt:

gentoo@standby ~ $ kermit
Connecting to /dev/ttyUSB0, speed 115200
 Escape character: Ctrl-\ (ASCII 28, FS): enabled
Type the escape character followed by C to get back,
or followed by ? to see other options.

  C to return to
  ? or H for this message
  0 (zero) to send the NUL (0) character
  B to send a BREAK signal (0.275sec)
  L to send a Long BREAK (1.5sec)
  U to hangup and close the connection
  Q to hangup and quit Kermit
  S for status
  ! to push to local shell
  Z to suspend
  \ backslash code:
    \nnn  decimal character code
    \Onnn octal character code
    \Xhh  hexadecimal character code;
    terminate with Carriage Return.
  Type the escape character again to send the escape character itself,
  or press the space-bar to resume the CONNECT session.
Press a key>----------------------------------------------------

 Device: /dev/ttyUSB0
Speed 115200
 Terminal echo: remote
 Terminal bytesize: 8
 Command bytesize: 8
 Parity: none
 Autodownload: on
 Session log: (none)
 Carrier Detect      (CD):  On
 Dataset Ready       (DSR): On
 Clear To Send       (CTS): On
 Ring Indicator      (RI):  On
 Data Terminal Ready (DTR): On
 Request To Send     (RTS): On
 Elapsed time: 00:00:46

(Back at
C-Kermit 8.0.211, 10 Apr 2004, for Linux
 Copyright (C) 1985, 2004,
  Trustees of Columbia University in the City of New York.
Type ? or HELP for help.
(/home/gentoo/) C-Kermit>quit
Closing /dev/ttyUSB0...OK

Not sure what I might be missing … Perhaps not a good converter?

On a side note, not important but just for my information:
I can boot into recovery from Android and also into fastboot.
But does Android support fastboot and adb over USB?
If one connects USB-C to PC would PC be able to fastboot and adb?
I tried but Andriod booted into Launcher and then rebooted and so on.

Hi, tasinofan:
Didn’t find any issues from the steps you described above, I think maybe something is missed, and kindly do following check again:

  1. Double check the RX and TX pin
  2. Try with another Serial Tool

Would be better:

  • Provide a photo about the connection between the Serial Tool and VIM2
  • Paste the .kermrc to us

You can also refer for further details.

Good luck!

Thanks Gouwa for kind support and reply.

I will soon be able to test another adapter as well.

I tried swapping TX/RX to no avail.
The adapter is documented

red = 5v (not connected)
green=tx (I connected to kvim2 GPIO pin 19)
white=rx (I connected to kvim2 GPIO pin 18)
black=gnd (I connected to kvim2 GPIO pin 17)


$ cat .kermrc 
set line /dev/ttyUSB0
set speed 115200
set carrier-watch off
set handshake none
set flow-control none
set file type bin
set file name lit
set rec pack 1000
set send pack 1000
set window 5

also user gentoo is in group uucp and
# ls -al /dev/ttyUSB?
crw-rw---- 1 root uucp 188, 0 Oct 22 00:45 /dev/ttyUSB0

Congratulations for your excellent products and community

[ photo with wrong pin connection deleted]

The photo of the wires connected to the wrong pin of the connector. Look at my website photo with a fan.
Pin numbers go from right to left (relative to your photo).
Look closely at the placement of connectors on the second photo link Gouwa. You have connected to terminals 2, 3. 4. You need 17, 18, 19 (they are on the other side). :slight_smile:

Thanks Oleg : I am truly sorry for the photo it : was not how I originally tested.
I will delete my photo in order to not confuse others.

[up/down left/right bottom/top … too many booleans and permutations for dyslexic me :slight_smile: ]

I got it working now : still it turned out the color coding on my particular converter was wrong.
I had to swap TX and RX and now it works!

Thanks all for support and nice hardware and software.

1 Like