Password requirement when fetching source code?


I’ve tried to fetch source code following this guide
But, i got an issue when “Fetching project android_packages_providers_CallLogProvider”. It hanged on!

I pressed enter and it required password,

i tried my github password but it’s not working

How can i resolve it?

Why did you go to download the repository ‘android_external_svox’? It is not exsit on github.

  1. You need to verify the file default.xml
    $ cd ~/project/vim/nougat/.repo/manifests
    $ git log
    $ git status
    $ git diff
  2. You need to verify the file manifest.xml
    $ cd ~/project/vim/nougat/.repo
    $ ls -ln manifest.xml

Give that informations for me.

Hi terry, I have the same problem,

I do not have a “~/vim2/.repo/manifests” in the working directory, but it has a “~/.repo/manifests”

git log

e[33mcommit cc7e19fd9c8585005304af61b4c308dfeda74560e[m
Author: terry
Date: Tue Sep 5 09:13:54 2017 +0800

Nougat: V170901

e[33mcommit 807e34d25a60663fb9cc2c27401537d39ddaab6fe[m
Author: terry
Date: Fri Apr 21 18:22:11 2017 +0800

Update to the V170421

e[33mcommit b46682e83ac85b130f37d8e9f5f36cce80fe0236e[m
Author: Gouwa
Date: Mon Apr 17 11:57:52 2017 +0800

device_khadas: only support broadcom serial wifi modules

e[33mcommit 900eeadeaeba286693eb4525bcda692b7139fb5ae[m
Author: Gouwa
Date: Sat Mar 25 18:24:57 2017 +0800

u-boot: set up the toolchain for BL301

e[33mcommit 62e0c325df2c57d891d02228d4d831fdbfdc145ee[m
Author: Gouwa
Date: Fri Mar 24 17:28:14 2017 +0800

fixup path: android_vendor_amlogic_system_modem

e[33mcommit b8ee6c2e19c9240128adfa91f3aa29978cc08275e[m
Author: Gouwa
Date: Fri Mar 24 15:30:51 2017 +0800

fixup! Nougat: V170321

e[33mcommit 4728d3be501e7de0de61a4a45cd993882078c29ae[m
Author: Gouwa
Date: Fri Mar 24 00:13:24 2017 +0800

Nougat: V170321

e[33mcommit 464c873114e858acc92daac4d9ec4e39d19f000ce[m
Author: gouwa
Date: Wed Oct 5 12:03:13 2016 +0800

Use 'github' as default remote excepts below large file repos:
1. prebuilts_sdk
2. prebuilts_qemu-kernel
3. external_google-breakpad
4. external_eclipse-basebuilder

e[33mcommit 0e874cc9092814f18e463f6dcc95ff17789f4d0fe[m
Author: gouwa
Date: Mon Sep 26 17:09:07 2016 +0800

initial commit for Khadas Vim

How to fix it?

@Vitak @mike1991.phil I’m sorry for that. The repository ‘android_external_svox’ is not exist on GitHub. I don’t know why the repository was deleted. Some peoples downloaded Android Nougat source code successfully two weeks ago.
I will update the repository at Oct 9.

@Vitak @mike1991.phil
The repository ‘svox’ was token down by Github due to the copyright

I updated the download link of svox repository to google server, you can download the source code again with ‘repo sync’ command.


I downloaded it successfully.

Fetching projects:  39% (206/527)  
error: Exited sync due to fetch errors
terry@terry:~/work/vim/nougat$ repo sync --force-sync external/svox

... A new repo command ( 1.23) is available.
... You should upgrade soon:

    cp /home/terry/work/vim/nougat/.repo/repo/repo /usr/bin/repo

Fetching project repo
Fetching project platform/external/svox
Retrying clone after deleting /home/terry/work/vim/nougat/.repo/projects/external/svox.git
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100     1    0     1    0     0      0      0 --:--:--  0:00:01 --:--:--     0
100 28.7M  100 28.7M    0     0  2127k      0  0:00:13  0:00:13 --:--:-- 3637k
Receiving objects: 100% (3391/3391), 28.69 MiB | 0 bytes/s, done.
Resolving deltas: 100% (1400/1400), done.
From /home/terry/work/vim/nougat/.repo/projects/external/svox.git/clone.bundle

You can delete whole exsit svox repository in repo and try again

# cd ~/vim2
# rm -rf external/svox
# rm -rf .repo/project-objects/android_external_svox.git
# rm -ff .repo/project-objects/platform/external/svox.git
# rm -rf .repo/projects/external/svox.git
# repo sync external/svox

Thanks Terry. It’s worked again!