OS08A10 camera not operating

I got the OS08A10 camera for some testing and on plugging it in to my vim3 I was not able to detect it with gucview.

any tips ?

Hello @Electr1

Which image you used? Have you checked with v4l2_test

@numbqq image is VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_SD-USB_V1.0.10-220108
With v4l2 test, I’m getting a blank screen on ts050


The /dev/fb0 device was opened successfully.
1920x1080, 32bpp
The framebuffer device was mapped to memory successfully.
fr_num = 1000, ds_num = 800
pixel fmt 0x33424752, width 1920, height 1080, wdr_mode 0, exposure 1pixel fmt 0x33424752, width 1280, height 720, wdr_mode 0, exposure 1pixel fmt 0x33424752, width 1280, height 720, wdr_mode 0, exposure 1Error: cannot open video device

1 Like

Can you check with HDMI cable? The demo may not support TS050.

I have tried with an 1080p HDMI display, still no output
It returns the same logs as above

I used another vim3 and it seemed to be working on that, so camera is not faulty.
seems some issue in its camera connector causing issue.

this time gucview detects camera and is able to show video at ~2 fps

Could you double check the connection is stable ?

You can change the resolution and fps in settings.

Yep i have checked, the camera connector on the other board is not working, it is not an issue it was just a test board.

@numbqq the issue has arisen again, this time I have used all the vim3s that i have to test, and the camera is not being detected again.

check dmesg log below:

I am not sure what happened, it was working well for a period of time and again it is not working :frowning:

Hello @Electr1

[ 0.000000] OF: reserved mem: failed to allocate memory for node linux,isp_cma, size:496 MB

Find some errors from the kernel, we will also check on our side.

1 Like


You need to setup in gucview.

@Frank gucview gives me the error saying video devices not found, and shows ionvideo and amlvido as options.

@Electr1 Can you try with the least release firmware ? I don’t do any change.

This was the same issue with newest 4.9 kernel firmware from fenix.

No output in gucview or v4l2 test.

Its working inconsistently, tested across 3 different vim3 boards, was working couple times before, but completely stopped working as of now.

Hello @Electr1

Could you take some high definition photos of the camera golden pins and CSI slot of the board?

I will provide them as soon as possible.

@numbqq here are some photos:

Hello @Electr1

Our sales @Sunny.zhao will contact you about the OS08A10 camera.

1 Like