OS08A10 8MP HDR Camera Android support

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Khadas official images

Please describe your issue below:

I’m trying to get image from https://www.khadas.com/product-page/os08a10-8mp-camera on my VIM4, but it writes that camera is unavailable. How can I enable it? Is there any nightly android builds to test? I want to test vim4 with my neural network

@Y2Kot Sorry, the firmware that supports this camera has not been released. If you need it urgently, I can provide patches or firmware for you to use first.

Yea, can you really prepare it? Its will be really good and help me.

@Y2Kot VIM4_test_update.img - Google Drive

@goenjoy I tried it in my app, and in frame processor I always getting images like this:

Is any way to fix this?

@goenjoy Is there any variants to fix frame processor?

@goenjoy Hello, is there any news? Can you share the rom with working frame processor?

@Y2Kot Can you send your apk to me?

I’ve uploaded sample source code and apk file on my github. Its sometimes needs to reopen app a few times to get broken frames

@Y2Kot I have tried your APK on the VIM3,VIM4 and Edge2 platforms respectively. The screen is blank when open the application.

I’ve uploaded new apk (with camera facing rotation). Can you check it please?

@goenjoy hello, did you check new app?

@Y2Kot I have tried your APK on the VIM3,VIM4 and Edge2 platforms respectively. VIM3 and Edge2 platforms is OK. The VIM4:There will be problems when you open it for the first time, and then click the HOME key to exit, and then click the application to enter. The image is OK.

@goenjoy you can reopen some times and it will break down again

@Y2Kot vim4-android-11-64bit-v221228----You can update to the latest version of firmware through owow. I tried this version of firmware without problems.

I still got wrong frames from camera even on the last version. It’s sometimes loads and work without problems, however it most often loads with broken frame processor. I’ve tested it on 2 vim4 and they both have this problem

Also there is one more strange problem with android frame processor. It works very slowly, usually it must take less than 1ms to get 1 frame, however on vim4 it took nearly 100ms to get 1 frame. Is it possible to speed up frame processor?

@Y2Kot Can you describe it more clearly? Including the steps of recurrence and the logcat with problems.

I still getting problems with camera frame processor - sometimes it returns broken frames. It don’t happens each boot, but it still happens. More often it happens on cold boot. Here is logcat - vim4 logcat · GitHub .

UPD: this problem takes place on CAMERA API 2, on CAMERA API 1 I didn’t notice this problems