OOWOW not accessible

I recently bought a edge2 PCB and from the very first time that I turned it on, I am unable to access OOWOW. After connect all cables and turned PCB on, led changes its colors showing some evolution, but it always reach the state in main led blink white like heartbeat eternally.
I tried to upgrade OOWOW using and sdcard and a usb adapter, but leds does not blink between red and white and goes directly to white heartbeat way after startup process. This makes me think that upgrade did not work.
I tried to boot OOWOW from sdcard but got no success as well.
Is there any other way that I can try to use the PCB?

Hello @hyphop

Please help to check.

Hello @francis.araujo

Can you press FUNC key and the shourt press RESET to boot into oowow?


Hi @numbqq,

I tried to boot into OOWOW this way and booting and holding FUNC key as well, but both procedures ended in same pattern: main led blinking like a heartbeat in white, no video and no OOWOW.


@hyphop what do you mean? It is to attempt to upgrade or boot OOWOW from a sd card? I already tried it and mentioned it in my first message.

sd upgrade card warranty works only for extension board not for usb adapter

PS: please provide UART boot logs its can help us solve your problem

Hi @hyphop,

It took some time to extension board arrive to my house, but now I have it. I have tested the board with extension to boot and to upgrade OOWOW, but with no success. The main led started changing colors and reach same state as I mentioned earlier, it blinks white like heartbeat eternally.

Also, I tried to debug using a serial port adapter, but I got no success to connect using minicom with board. I have a video published at Trying to debug Khadas Edge2 using serial adapter - YouTube.

Is there something else that I can try?


1 ) led indication looks like works well and oowow started
2) check uart connection Edge2 Setup Serial Debug Console [Khadas Docs]
no succes with uart no problem

we have other options to get headless access to oowow device

web interface usage demo http://dl.khadas.com/.temp/oowow/screencast/wizard-web-demo-2-minutes.mp4

1 Like

Hi @hyphop,

It worked!! I was able to access my board using hotspot, changed network configuration to my cable and installed ubuntu on it.

Thanks a lot for your time and patience


1 Like