OOWOW dangeon explore, eMMC to USB and vise versa

Which system do you use? Android, Ubuntu, OOWOW or others?

**A. Ubuntu server installed via OOWOW B. Debian server built from "github/khadas/fenix" without 'make kernel-config' **

Which version of system do you use? Khadas official images, self built images, or others?

**A. Ubuntu server is Khadas official image directly via ethernet cable. B. Debian server is from "github/khadas/fenix" , so called *.img file in the build/image directory. This *.img 'copied' into USB memory stick for eMMC write. **

Please describe your issue below:

A is perfect for both eMMC image backup to USB Stick and also restore from it to eMMC. It is fine.
B is OK when installed via OOWOW into SD Card. SD Card is the highest priority and boot successfully. BUT image write to eMMC boot failed. no screen and then OOWOW shows up. Image file for SD Card and USB stick for eMMC write are different followed by ‘setenv.sh’ instruction.

By the way, my VIM1S boot OOWOW with Function + Power sw. Is it something wrong???

I appreciate your advice. Please let me know how to fix.


I still am unable to write image of my own built to eMMC, on the other hand, I could successfully write image downloaded to USB drive.
Further I am in failure on my own image build with following message. Situation is going worse.

Info: Simple raw image suitable for dd write → vim1s-debian-11-server-linux-5.4-fenix-1.5.1-230625-emmc-develop.raw.img
dd: failed to open ‘/home/foobar/Project/khadas/fenix/build/u-boot/fip/_tmp/u-boot.bin.sd.bin’: No such file or directory
make: *** [Makefile:2: all] Error 1

Yes, there isn’t ‘u-boot.bin.sd.bin’, but is ‘u-boot.bin.sd.bin.signed’. I found similar occurrence on this forum, but script is much different. It does not help directly. More learning is required…

It is very hard to find out which script miss ‘.signed’ as postfix. A couple of u-boot image files as UBOOT_IMAGE_FILES those are ‘u-boot-bin.signed’ and ‘u-boot.bin.sd.bin.signed’, but some script request to add ‘u-boot.bin.sd.bin’. I am still trying to find…

I found it ! not script itself, but how to use fenix script. Is this a sort of entrance exam for joining this community? Fenix script is imperfect as of today 23June28. I should have been skeptical why ‘u-boot.bin.sd.bin’ is required for eMMC image though it is prepared for SD Card. I tried writing image built for ‘SD Card’ to ‘eMMC’ via OOWOW. OOWOW! is successfully write image prepared for ‘SD Card’ by fenix script. I enjoyed this trick. Thank you for keeping friendly silence. I will install my own build image to eMMC.

problems was solved ?

Yes, I became able to build an image on X86_64 machine and write it via OOWOW to eMMC.

TIPS: easiest way from linux host VIM1S Install OS into eMMC via OOWOW [Khadas Docs]