Onboard mic & HDMI in

Is HDMI in now detectable in your latest image of ubuntu?

are the 2 onboard digital microphone now detected and usable?

i have been away for a while, and last time i asked both of these thing were not yet possible in ubuntu.

Hello @Shazam1990

Yes it is possible to use the HDMI-IN and mics.

Please check the documentation in relation to this.



after installing the latest ubuntu image, i am unable to get the desktop to fit my screen so some part are not viewable. How do i fix this?

What resolution is your screen ? can you show some pictures of the desktop clipping ?

The Screen is an LG Web OS LM6300PLA

here are the resolutions currently offered to me in ubuntu, but none fix this issue

also i have just got connected to the device using RDC but even though connected no desktop appears. but if i right click anywhere on the black screen i get a context menu

Hello @Shazam1990 I think this is an issue from your TV settings, can you try checking your TV settings to make sure any kind of picture zooming is disabled ?


@Electr1 i have fixed the scaling issue. it was in fact a setting in the TV called “Just Scan” i turned this “on” and now i can view the entire screen as expected. so thats 1 issue resolved.

However my remote desktop connection still shows a black screen once connected. if i right click this black screen a context menu shows up on the screen connected directly to vim4

@Shazam1990 that is because the VIM4 uses Wayland default for desktop, not X11, so X server based forwarding will not work. the solution for this is to either remove all wayland packages and add x11. (warning: its is CPU based acceleration and is very slow)


Other choice is to use a wayland based remote desktop utility, gnome-remote-desktop package can allow you to start access for remote desktop from the GNOME desktop by default.


@Electr1 thank you for that information.

In regards to the HDMI in i have successfully managed to get the hdmi-demo to produce the image of the hdmi input. However when i close out of it it takes me to a terminal rather than back to the desktop environment why is this?

Are there any programs currently that can see the hdmi in as a input capture device? And is audio carried over hdmi in also?

That demo for the 5.4 kernel only worked for the framebuffer mode capture.

You can try the 5.15 kernel image, it has solved this


Regarding audio I am not sure, need to check with developers, will get back to you on this next week.

can you reccomend any software to view the HDMI in as a capture device? i can’t seem to find any programs that detect the input

i also cannot get the onboard microphones to work.

i am using the latest test image with the 5.15 kernel

Please try,

$ arecord -D hw:0,3 -r 48000 -f S16_LE -c 2 -d 10  test.wav

here hw:0,3 is relating to the adapter id for the sound card for the PDM microphone
you can check all devices with arecord -l

Is video input capture successful with gstreamer example ? Have you tried gucview ?

arecord -D hw:0,3 -r 48000 -f S16_LE -c 2 -d 10 test.wav

@Electr1 This worked. thank you. its great to see & hear it working. Can this be used OS wide yet for things such as VOIP applications?

Video input capture works for the first 3 seconds, but then for the remaining 7 seconds the screen turns white/grey/blank

gucview just gives lots of options when opened says no video device found (/dev/video0) then below give a long list of items. none seem to show anything

Could you share some logs from dmesg, it will help us to debug the issue.

The respective video device is /dev/video71 for HDMI Input.

Need to verify this, I will get back to you on this.

@Electr1 here is the dmesg log

10 second clip plays for 3 seconds showing the HDMI content but then switches to this for the remaining 7 seconds…

gucview just gives lots of options when opened says no video device found (/dev/video0) then below give a long list of items. none seem to show anything

this option is not shown at all i do not see (dev/video71)

Okay we will try to debug this and get back to you regarding the solution.


@Electr1 thank you. Whilst i await your response on this can i ask…is there any method currently to listen to the audio coming in via the HMDI input? if no, please can this be made possible

my end goal here is to hopefully use the VIM4 as a capture card

@Electr1 any update on the hdmi-demo issue? or any progress on the HDMI input as a whole so applications can detect input devices?

@Shazam1990 the HDMI in works from my side, what device are you trying to record with the HDMI ?

It may be high chance that your device has HDCP/DRM Protection enabled.

@Electr1 i am using another mini PC to output its screen to the vim4s hdmi input. it shows correctly at first as stated before during the “hdmi-demo”, but then it just goes completely grey. and no programs in ubuntu are detecting the hdmi input device you mentioned “dev/video71”