[Official OS] Home Assistant OS - Vim3


Home Assistant Developer Agner have worked on Vim3 port and have pushed it to Dev branch of official Home Assistant Git.

I have just built it from their git branch and publishing it here so users can try it out and give feedback. With Official Release of HASS OS 7 Khadas Vim3 image will be available directly from Hass team.

I present to you a Dev Official Image of HASS OS for Vim3.
HomeAssistant Official Release Git

All credit to Hass Developers who have worked on Khadas device support.
Users please try it and share your feedback.


thx for this notification !

I recently bought the VIM4 with hopes to use it with home assistant. I attempted to use the vim3 image already created but didn’t seem to do anything. Has anyone else with a VIM4 try been able to? I know they are new, what would be required to make a new bootable image ( from https://github.com/home-assistant/operating-system/releases/ )

at this moment not ready ! but every time u can use our ubuntu images and install home assistant inside ubuntu, for example line on next video

1 Like

For a bootable image you will have to wait for mainline uboot and mainline linux kernel which might take long time given how new the A311D2 soc is.

You can always try the solution provided by @hyphop above.

Use khadas official ubuntu image and install home assistant on it. Using docker version will give you supervisor access too so it will be the same as Hass OS.

Thanks, that is what I ended up doing. So far it is working way better than Hass OS on my RPI.

1 Like

I am very happy with hass on vim1.
Even vim1 is faster than my older rpi3b+


Tried this image. Can’t write it to emmc. What type of installation shuold i use?

My image is very old now.

Please use official latest image from here

To flash it on emmc you need to dd it on emmc somehow.

I might make one image which would boot into a small linux userspace and flash the actual image to the emmc.

@hyphop Please add dd support to oowoow/krescue so users can just flash a raw img to emmc.

Trying to use owow or kresque for this aim. But can”t import this image into dd manager.

dd and other linux core commands already inside oowow

1 Like

can I run it from HDD?


  1. I installed https://dl.khadas.com/Firmware/uboot/main-line/VIM3.uboot-mainline.emmc.aml.img to eMMC via USB_Burning_Tool
  2. I installed HAOS VIM3 variant https://github.com/home-assistant/operating-system/releases/download/9.3/haos_khadas-vim3-9.3.img.xz via balenaEtcher to HDD - connected inside ugreen USB3 case and USB external 12V power hub (the same connection used to work with my rpi3b which had only usb2.0)
  3. Not working - also when directly connecting HDD enclosure to USB port (without hub) nor with it

Not booting.

Could boot it though with https://dl.khadas.com/firmware/vim3/ubuntu/generic/vim3-ubuntu-22.04-server-linux-6.0-fenix-1.3-221118.img.xz

please provide full boot log it will be more usefully for us