NVME support in OOWOW

Congratulations for OOWOW, it’s a great advance from krescue, of which I was already a fan.
My biggest need that the latest build doesn’t yet support is NVMe. I am round-tripping images and the dumps partition of an OOWOW MicroSD between the VIM4 and a second laptop, and it’s kind of terrible. :slight_smile:
— Jeremiah

My biggest need that the latest build doesn’t yet support is NVMe.

will be soon , problem not in oowow which already can write it to any location same as NVME and USB
for example Krescue with VIM3 / VIM3L easily can do it

we need prepare suitable image for what

  • uboot which can start kernel from nvme not ready for VIM4

PS: at this moment we can store /boot files on emmc and NVME storage will be mounted later


u can store restore dumps images by network

1 Like

That’s how I’m doing my boot now - but it’s “blind” after start. The EMMc is an unpartitioned raw Ubuntu image, available to uBoot - but so far unmountable by me from the NVMe root. I tried calculating offsets, but so far no luck.

Also, NVMe root is inconsistent and unstable under the current fenix-buildable Ubuntu images. I’ve tried to make several now, and to rsync the regular supplied desktop image. Some boots are fine, some spontaneously reboot themselves. Most end up having block storage problems after medium usage of the NVMe after some time. It may be the .dtb needs work? I fixed this a couple years ago for MacBook Linux and NVMe drives, but none of this effort has applied when I tried on the VIM4.

All of these images work “like butter” on the EMMc, with a desktop experience that leaves nothing to be desired, except… SPACE!

  • please build ubuntu sd image (not emmc) its same suitable for emmc
  • write this iamge to emmc for example via same oowow
  • etc …

PS: at this moment we try to improve and fix some problems for ubuntu images and make release later

Yeah, that’s my Saturday plan. Thanks.
Right now, the SD reader doesn’t seem to work right for an image I made, though it WILL work with an SD OOWOW card. It worked when I didn’t have the MX2 & NVMe attached.

I’m going to try the network loading you’d mentioned. I’ll give results back.

SMB networking doesn’t work from my setup. Authentication errors. I suspect it’s because I’m SMB v3 on my Armbian/OMV NAS, and the cifs client in OOWO doesn’t handle it.

I used SCP to copy an image over the wire, and managed.

— Jeremiah

NOTE: NVME not ready for VIM4 for normal usage

wip … will announce it later when its will ready and tested

Thanks. I have an image on NVMe, but you are right. It’s unstable!

SMB / CIFS same need to improve wip…

BTW: oowow smb example

root@vim4-00064:~# df | grep //
//   8388608   3076204   5312404  37% /tmp/mounts/smb-usb-krescue
root@vim4-00064:~# ls -l1 /tmp/mounts/smb-usb-krescue
-rwxr-xr-x    1 root     root     687865856 Jul  5 05:52 vim4-220705.055208-31268536320-bytes-emmc.img.zst
root@vim4-00064:~# grep cifs /proc/mounts 
// /tmp/mounts/smb-usb-krescue cifs rw,relatime,vers=3.1.1,sec=none,cache=strict,uid=0,noforceuid,gid=0,noforcegid,addr=,file_mode=0755,dir_mode=0755,iocharset=utf8,soft,nounix,serverino,mapposix,rsize=4194304,wsize=4194304,bsize=1048576,echo_interval=2,actimeo=1 0 0
1 Like

I’m impressed that every issue I have mentioned, is already known by two of you, not a new RFE.

— Jeremiah