Non-Linux users -Installing Linux/Debian

Hi Guys,
Finally got my VIM v.1.2 yesterday. I need to ask a very basic question to you guys. I am a software programmer who works 80% on windows and 20% on Linux (rasbian and ubuntu) via bananapi and raspberry pi systems.

Now I am planning to install ubuntu/jessie through USB adapter with led inserted. I am running out of luck each time I do so. I don’t have much experience like you guys have to deep dive into Linux.

I wanted to run Nodeji, mongodb and as an application service on VIM Board. I badly need your help to run command line only Linux distro (pref debian) on SD card only and use internal emmc card for our application and database use.

I cannot make VIM work due to lack of Linux knowledge… please give me some non-programing instructions that I can readily write the card and insert into VIM, so that I can log into SSH right from the beginning.


Have you read this topic ?


Thanks for your reply.

I did try Armbian_5.27_S9xxx_Debian_jessie_3.14.29_server_20170808.img.xz and followed setup the process which you had given;

  • After updating the box; the system never boots and it’s always blank.

Then I downloaded the Armbian_5.27_S9xxx_Debian_jessie_3.14.29_server_20170808.img.xz

  • This worked; loaded, but resolution; I couldn’t see any thing which is going on the TV, tried connecting to LCD monitor (resolution); with a great guess work; I did change the password;
  • SSH doesn’t work, I cannot connect to the device; both in wifi mode and LAN.
  • Changed IP from DHCP to static via (armbian_config), no improvement.

I am really stuck; I have been working on bananapi for quite some time now (just minimalistic config)

1366 x 768 is LCD monitor’s display setting currently, i am connecting my broken laptop and working.

requesting for help


  1. If you use the batch update images Debian (apt upgrade), you need to disable a test repository settings “apt”. The latest packages from the testing repository of Debian destroy the system.
  2. According to your description of the behavior - you have a bad media or an image. Try to download a new image, unpack and write again. For initial tests I recommend to use a USB flash drive.
  3. To use WiFi it must be configured correctly. To load manually the module, configure the connection and to verify the work. If everything works, add the startup of the module in the file /etc/modules.
  4. You can use only two options of screen resolution - 1920x1080 and 1280x720. The resolution is done via editing the file /boot/ Details of how to do this - there are on this forum and on the forum Armbian.

I suggest you to check threads on the forum Armbian, there are answers to all your questions.

Thanks for the Info!!!

pls suggest a location where I can get a good image of (ubuntu server / debian server)- that works with VIM and SSH