No display after Booting on hdmi without desktop VIM1s

Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu-server 5.15

Which version of system do you use? Khadas official images, self built images, or others?

Khadas VIM1s

Please describe your issue below:

I work with Khadas VIM1s, Ubuntu-server kernel 5.15 without Gnome Desktop.
I have created a service who launch my application coded with Qt with the plugin linuxfb.

When I plug the HDMI cable on the VIM1s, I see the boot logo KHADAS stay on the screen, but my application not displayed on HDMI.

I have modified the /boot/uEnv.txt and add this argument:
I rebooted and I have the same phenomenom

Could you have a solution?

Hello @jean_88

How about boot the system with HDMI cable connected? Does the display works well with the original images?

I tested with ubuntu-gnome-5.15 it works on HDMI and displays the desktop.
My problem is that I no longer want to display the ubuntu desktop but display my application instead when starting vim1s.

I use a waveshare screen 4.3". I try to disable the gui (gnome) with the command sudo systemctl set-default
Then I reboot the khadas vim, I see a part of the Khadas logo.
If I switch off the screen and I switch on the screen, the desktop appears (I don’t know why it appears even though I have disabled the desktop! ).

@jean_88 is your application displaying normally when you enable startup without the service ?

Without a service, my application runs normally

@jean_88 can you share your service entry ?

Can you try disabling the service and appending the launch command for your application at the end of /etc/rc.local

This is my service:
Description=Service start app

ExecStart=/bin/sh /opt/


and my
export QT_QPA_PLATFORM=linuxfb:fb=/dev/fb1


I try to put my application at the end of /etc/rc.local before exit 0 it does not work.

Have you checked if your service starts with any error with systemctl status?

Is usage of /dev/fb1 correct ? Have you tried /dev/fb0

I will see if I can try some sample application from my side and let you know.

My service starts with no error and I tried with both /dev/fb0 & /dev/fb1
and I have the same issue

@jean_88 can you share your application binary to test ?