New VIM2 doesn't work

Hi all
Today arrived my VIM2. I connected to adapter 5v 2A and connected to TV via hdmi. But didn’t see anything. Black screen and nothing. Tried other adapters, hdmi and TV. I guess the board is dead. How can I check?

@NewAger

  1. If you have serial tool. You can follow this docs to check if it have any output with serial tool.

https://docs.khadas.com/linux/vim2/SetupSerialTool.html

  1. If you don’t have a serial port tool, you can take a video to record the process and operation of your power-on, focusing on the status of the lights.

Hi Frank
No lights when plug to power. Is it broken?

@NewAger

  1. Did you have a serial tool ?
  2. Maybe the OS is broken, not the board. Can you try to boot into upgrade mode ? If you PC can connect you board, you can reburn a image.
  1. Don’t have
  2. I have mac. In documentation instruction for PC or Ubuntu

@NewAger Your board version is V14?

  1. Can you try with TST mode( Quickly press the Function key 3 times in 2 seconds, then release the key. You will see the Power-LED (Blue) blink for about 3 seconds.) ?
  2. Please record a video for us.

I watched your video, the power cable in the video looks like the power cable of our 12V2A adapter?
Are you sure you are using a 5V2A power supply, can you take a picture of your power supply? If you use a 12V adapter, the board will not work.

Hi
Cable from iPad. First time I plug into computer. I tried charger 5v1,5A
Also tried 5V3A. Doesn’t work

@NewAger Our after-sales colleagues will send you a private message.

I found problem. It is doesn’t work with cable USB-c → USB-C
Do you know why?

@NewAger I think it’s the adapter’s specs that are wrong. I suggest you find a 5V2A adapter and try again.

With usb - usb-c wire works good. But usb-c - usb-c didn’t

USB c to usb c prob means that the charger is a USB c power delivery charger and whilst there is a USB c port it’s not got the sense resistors on it to make the power supply start delivering power. That would be my guess