Need help on using tone2 pro on ubuntu 20

Hi, all

A newbee here. How to use tone2 pro on ubuntu? Is there a guidane, I couldn’t be able to switch my audio output device to tone2 (it’s not an option for me). Tried to follow this guide. But I don’t hear anything after the configuration and using mpd. Thanks!

Hello, Welcome to the community. To ensure the T2P is in the correct state, check the following two videos on the volume encoder’s functions. Specifically the input mode…
Vid1, vid2.
User Manual.

Thanks, but I fully understand the knob…And after seeing your suggestion, I check again, to make sure it is in the right status. (Connecting usd-c, so use that as input)

Should anything be configured for ubuntu? Or should I have plug in and play user experience?

I have not used the Tone 2 Pro on Ubuntu lately and won’t be able to try it until tomorrow. If I recall correctly, it was like plug-n-play, but I cannot be certain.
Until I get a chance to try it, perhaps @Spikerguy , @Electr1 or @Vladimir.v.v could have the answer.
Until then, have a look here.

1 Like

no Idea, however from this guide from Hyphop you might get to know how to setup on Linux, Tone2 Pro - Bit Perfect Linux Audio - YouTube

1 Like

It was not plug and play as far as I could tell. Regrettably I did not have time to pursue it further. I will pick it back up tomorrow.
Until then, perhaps @Eric68 could give some tips.

@RDFTKV Thanks for your reply!

I did not find the solution for Ubuntu running on my VIM3.
However, I booted Ubuntu live on my laptop and it was simply plug and play and worked straight away.
Hopefully someone from Khadas can explain how. @tsangyoujun


Yep, for Ubuntu on X86 just plug and play, and also similar on ARM64 Ubuntu expected you wanna enable the Native DSD decoding.

Can you post a screenshot to us while you plug your Tone2 Pro on your PC.

1 Like

I am on x86
and I am on Ubuntu 20.04.2 LTS, 5.4.0-74-generic

It seems, t2p is detected

But I couldn’t change my output device here, there is no option:

Thanks you folks!

1 Like


Maybe @hyphop will help out?

i think problem is PulseAudio check this post > Tone2 Pro / Tone1 + Linux + MPD == how can get max perfomance

  1. check /etc/udev/rules.d/89-pulseaudio-usb.rules maybe your tone board skipped by this config -> solution try remove this config and restart pulseaudio
  2. try remove pulseaudio and try to use pure alsa

Thanks! I will try it later today

I reinstalled pulseaudio, and tone2 is detected.
Although I still suffer from ubuntu’s weird no sounding problem…t2p part is working correctly I think.
Thanks folks

1 Like