Need help!KT2Pro blinking blue, not recognized by PC

Hey ! My Tone 2 Pro is blinking/ flashing blue in different strengths. What do I do now? The KT2Pro is the only DAC/AMP i have since I’m running a minimalistic setup.

Please help @Eric68 @Gouwa @tsangyoujun

Best Regards

Hi Thomas,
Are you able to provide more details on this? Basically, a short video will be help out for us to understand the issue.


Hi Thomas, it sounds like your Tone2 Pro is not receiving sufficient power from your USB cable.

  1. Switch to a different PC or mobile device
  2. Plug external 5V power into the I2S port

Hey. Thanks for answering. It’s still blinking regardless of power. It’s blinking very light blue- light blue- blue over and over. Tried different cables and sources. Even a powerbank. What to do?

How do I post video here?

You can post it to YouTube and paste the link inside our forum like so:

Not sure if you were powering the T2P with mobile phone directly?

The iPhone cannot drive Tone2 Pro but some Android Phone might able to drive T2P.

dear . i have same problem;

blink blue, and popping sound is heard in the headphones.

Did you upgrade the firmware?

And I reinstalled the drive but it doesn’t recognize it.

Sufficient power is also supplied.

in my problem video

Never used an iphone. I’m driving it with my Laptop. It has worked for months. When i connected it a couple days ago, it just blinking blue and laptop doesn’t recognize it. It seams dead except of the blinking.

I’ve tried :
Different USB C cables
Different USB inputs on Laptop
Other power sources as f.ex Powerbank and L2S port
Reinstalled Firmware, but nothing is happening since it can’t recognize it.

Im gonna film the blinking.


Are you able to show us with more information below:

  • The connection between the T2P and your PC(the White USBC cable showed in your video)
  • The setup & connection of the LPS power supply(red USBC cable)


Does you issue similar with the video posted by @kokoeunjun above?

Will address out the issue :slight_smile:

@Gouwa Yes!it’s exactly the same!:slight_smile:

You also setup with LPS Power input? Are you able to take a try with only one USBC cable and connect to a USB3.0 port?

BTW, a photo or a video of the setup will be helpful.


i connect z390 extreme4 mainboard back usb-c port / to using included cable.
and using 20w PD4 charging cable (red one ) and 18w qc 3.0 charger.

and after uproad this video, my T2p works again.
i dont know why, It seems to be overcharging or overheating.
If I am not using T2P, is it recommended to disconnect the power and data connection?
Or is it okay to keep it connected?

It’s fine to keep it connected.

Not sure which QC charger you are using, the T2P support standard USB-C PD charger but not QC charger(we not suggest setup power in this way, but with good quantity Linear Power Supply instead).

Are you able double check only with your White USB-C Cable connected for both USB Data and Power?

Edit: are you able to provide us the model number of the 18W QC 3.0 charger? Not sure if the charge output with voltage higher then 5V, in that case the T2P will work in ‘protect’ mode and keep reseting the power and will be similar issue like the video you posted.

1 Like

No. I only use USB C from the Khadas T2P to my Laptop. And i use iem/headphones with the 3.5 input or 4.4. i don’t use anything else. And this have worked for months. I don’t know why it suddenly stopped working! But it’s really anoying since this is my DAC/amp now.:frowning:

Just double check the USB port of connected is USB USB3.0 or USB2.0? Just note that 500mA of USB 2.0 standard might not insufficient while high-res audio is played.

BTW, are you able to shot a photo to show us the setup & connection between T2P and PC?

Remember to:

  1. Unplug all USB-C cables
  2. Replug just one cable into the (USB) port
  3. Long-Press the volume knob to reboot your Tone2 Pro

Doing this after updating the firmware will allow your PC to recognize it.

Scenario B: If you see no lights at all, that means the MCU is blank. Reflashing it with the v1.2 MCU firmware will fix the problem.

@tsangyoujun How long do I need to press? Just did exactly what you suggested, but still blinking blue. I pressed down for 1 minute.:frowning: