My VIM4 does not power on


I received my Vim4 just before the weekend and it does not power on. I have tried many different USB C cables and I’ve tried connecting it straight from a USB-C power supply and connected to my computer and I get no response.

Is there something else that I can try to get it workin? Or is it just faulty?

Please contact me as soon as possible to figure out what the next steps should be.

Best regards
Steinthor G. Hafsteinsson

Do you have a lab power supply, if so cut the connector off the cable and connect it direct to the power source. See if it actually draws any current, that would be a start.

It takes a good power supply, did you get the Khadas factory power supply?

what about led indicators - any activities ?

There is no LED activity. And it Shows no activity at all no matter what the powersupply I use. I connected it to a 60W supply which I think is my largest and no reaction whatsoever.

Can I contact the Khadas team over e-mail

i think need make request to send it back ! ask about this @rubywen

Hello dear
May I know where did you purchase VIM4? on Khadas shop, AliExpress or Amazon?
Would you mind sharing with us the item list including VIM4.

I bought it in the khadas shop.

We’ve received your order.
We’ll let you know when your items have been shipped.
Order No. 15185 Placed on Jul 23, 2022

Hello @rubywen
I bought the board from the khadas shop, with the cooling kit.
Do you need more info?
Can we move this to e-mail so we can arrange for return etc.?

Hello @SGHice
our team @Sunny.zhao will follow up the after-sale services.