My VIM2 does not boot after flash

I’ve tried to flash my VIM2 (Amlogic S912 / 3GB / 32GB) with USB_Burning_Tool_v2.2.0 with
and the burning process stopped on 7% for 3 hours.
since I tried to flash it again but the USB_Burning_Tool_v2.2.0 could not connect to my SBC :zipper_mouth_face:

I was searching on the net from the last week to find a solution before posting this request but I couldn’t fix it.

I’m trying now to dump the firmware directly to EMMC via UART but I’m facing a loop trying connects “Please check the UART below”

I must have been missed something and I wish someone to help

Best Regards

Hello @MohammedMatar

You can follow this documentationt to boot into upgrade mode and reflash other images again.

I’ve tried all of them

  • TST Mode: The SBC will not load anything after press the Function key, only black screen with no signal and the Power LED didn’t blinks at all.
  • Keys Mode: Same problem as long there is no boot all.
  • Serial Mode: I think the only hope will be from this solution but I’m facing the current problem which is mentioned in my topic.

Thanks a lot for quick replay, wish more solution if it is possible.

What’s the hardware version of your board ?

Amlogic S912
1.5 GHz 64Bit Octa Core ARM Cortex-A53
750MHz ARM Mali-T820MP3 GPU
HW UHD H.265/VP9 60fps 10bit video decoder
HDR10 and HLG HDR video processing


I’m now able to connect to my VIM2 through minicom and puTTy with my UART cable.

but I couldn’t find how to boot from the SD card, it is not loading

Hello @MohammedMatar

Can you try to boot into upgrade with the Mregister mode?

I’m really confused, I’ve even discover new methods to login to my VIM2 but the boot has a problem, please advice me based on the attached screenshots, which is the best way to flash the boot.

please check also these screenshots

by the way, this is my device specification

The GO processor - Amlogic S912
Number of cores - 8
Graphics - Mali-T820MP3
Flash memory - 32GB
WiFi: 2.4/5GHz IEEE 802.11 b/g/n
Bluetooth: Bluetooth 4.0
LAN - Ethernet 10/100M/1000M
Video output HDMI 2.0 support HDR, CEC and HDCP 2.2 and 4K*2K resolution
Connectors: 2xUSB2.0, Optical S/PDIF, RJ45, microSD card

I’ll appreciate any advice
Best Regards

I’ve fixed, I will post a tutorial for reviving my device process with a detailed screen shots in new post because many users reached dead end without solutions.

It takes from me one week to come up with new methods that I’ve never seen even with my google search.

Thanks for helping and hope you close the post.