MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC


#204

Hello, Balbes150!
Thanks for your kind support.
But still to no avail. Rewrote /dev/bootloader (error message : it’s full then confirmation of writing x kbytes?).
Am installing your latest 3-1 (seems I’ll have to stick to it for now).
Have a nice vacation!!!


#205

Hi!
I’ve installed the latest 3-1 (20180625).
Boot to android.
Impossible to boot to linux/librelec (I get the reboot menu with the choice of OS).
Managed to ssh to android via simplesshD. Can’t use setbootenv.
The noob is still a noob and still at a loss…
Thanks for tour interest!!


#206

After multiple attempts, it finally made it.
Can’t fathom why it finally decided to work as expected??


#207

Hello, I have a problem with VIM2, when I boot on sd card CoreELEC no longer boots multiboot just android, if I select ubuntu or libreelec boots everything in android. In eMMC I have MultiOS_3in1 (Android + Libreelec + Linux).


#208

In Coreelec still use the old multi-boot system that can work only with android.


#209

@balbes150 Hi, I would like to ask you for your help - I´m using your latest version of Libreelec on microSD card on Khadas Vim2 Max and from that system is impossible to power it off. I tried it from LE menu and also power button on Khadas.

During power off session blue led on Khadas only blinks and start again.

Do you have any idea, how to fix it?


#210

What firmware is installed in eMMC ?
What previous experiments did you do with VIM2 ?
I would recommend to start with restoring the standard firmware via USB cable and USB Burn Tools program.


#211

Hi, I have latest version of Android… Ok, will try it…


#212

I have made clean install and power off from Kodi is not working. Do you have any idea why? Thank you


#213

Write down exactly all the steps you did when installing clean firmware and running LE.


#214

Flash via usb burning tool latest android.
Download LE, unzip and via win32diskimager flashed into misco sd card.
Boot from android.
Once it´s done, connect miscro sd card and do system update via aml_autoscript.

So do you have any idea please?

Edit: If it helps you. I´m using Khadas remote controller. On clean android is similar power issue. Short press power button caused sleep mode as defined in powerkey functions in Android settings. Long press power button caused power off. But in LE is impossible to do long press power button and it caused restart mode same as short press on remote controll. Also when I´m trying to power off from LE menu, it will also do only restart, even if I choose power off system…

And I have also delete dtb.img from root folder, from device trees folder copied kvim2 to root folder and rename it as dtb.img. But in this case, it won´t boot…

For you power off works on KVIM2?

There must be something wrong with Khadas and LE (also testing CE with same results). Even ssh commands (shutdown -h now) does the same and won´t power it off. Pls just let me know, if it works for you or not. Thank you.

Because now the only way is to boot back to android and power it off from them. But it makes no sense as I think other boxes power off properly.

Last edit: I have tried now LE 8.2.4.1 and power off works without any problem.

Latest edit:
There must be bug with Khadas remote controler.

After of many hours of investigating I found bug. Presence of Khadas remote config files caused on Khadas VIM2, if you press power button only restart, not shutdown.

Not possible to test it in LE, as this remote controller is built-in LE, but I have tried it in LE 8.2.4.1. Till no config file for this remote controller was in system, power off worked properly. Once I added it, power off always caused restart, not shutdown.

Can you please fix it?


#215

I’ll check it out soon.


#216

Hi, I think, I have found, where is the problem as per thread below.

Can you pls take a look and let me know, how this can be fixed? I think it´s problem of Android ROM (I have tried all Khadas ROM´s with same effect), what do you think?


#217

The directory with the latest archive “KVIM2-emmc.tar.gz” added update for Libreelec, which is used in MultiOS_3_in_1. Install the LE standard update, copy the file “.tar” into the directory “UPDATE” (on the network at work LE), and restart LE. The update will take place automatically.


#218

Hi balbes150, I would like to ask you, if I firstly have to install MultiOS_3in1 and then make update or can I have latest Android firmware from Khadas site, install LE into SD card and then make update? Thank you very much for your clarification


#219

This update is only for MultiOS_3_in_1. The LE to run from external media (and install to eMMC as a single system) is discussed in another topic.


#220

Uploaded the next update Libreelec (tar) version 20180831.


#221

Thanks so much for the update
I guess I must search for a S912_EMMC.arm tar right?
But I don’t seem to find it. Can you provide link?
Also, I do not seem to be able to download from your Yandex shares anymore (see (*)).
If you can provide alternative location that would be very kind.

[(*) I also tried with a new Yandex account. When downloading I am asked for login but after I login nothing happens and log in button still there. Same for saving to my Yandex disk. I already asked for support but no reaction.]


#222

Hi Balbes,

could I also use this update when my current libreelec version is 17.6_20180122?

I am asking myself if I could place this tar file in my libreelec update folder as it is currently kodi 17 (17.6_20180122) and as far as I know your libreeelc build is already on kodi 18


#223

The KODI-18 version for MultiOS_3_in_1 uses the new LE startup script, so you must either manually replace the script in the /dev/multiboot section or use a new system installation in eMMC to upgrade to the new version.