Manjaro minimal


As you may guess from my other posts, finally I’m trying the VIM3, I copied the krescue image and from there installed (by wifi which was amazing!) the minimal version of Manjaro.

Once in manjaro I did a system upgrade via pacman and realized while doing it that the heat sink went quite hot. I tried to turn the fan on but failed.

I checked with ps and systemctl to see if there was any daemon that may suggest a fan control, didn’t find any. Then turned into the forum and noticed that there’s a fan script, I found it on /usr/bin/fan. Tried to run it and noticed that i2c-tools were missing, so I installed it.

Then it still failed to find the i2c binaries, noticed that it is using which to identify them but oddly which is found? (I thought that was an internal command of bash?), anyways, installing busybox fixed it but still can’t turn the fan on, I get:

i2cset: can’t set address to 0x18: Resource busy
[i] set FAN SPEED: 1

Is there something else that I should do?


1 Like

I suggest asking @Spikerguy

No the fan will run automatically when the temp reaches 80°c as set by the kernel developers.

You can install cpu-temp-speed to check the current temperature.
Vim3 doesn’t really get hot as compared to other soc’s if you have the official heatsink to it is enough for the device to run under heavy load, fan cooling is just a bonus.

If you want you can reduce the tripping temperature for the fan to start.

Full discussion about fan in mainline kernel can be found here.