Mainline Kernel Boot Error

We’re working on making the Mainline Kernel boot on Vim1 and we’re stuck with the follow error. We tried Mainline kernel with Vim3 and it booted fine.
Error Log when using the unmodified boot scripts and then we changes the dtb_mem_addr to "0x9000000" and now there is no fdt error but "Synchronous Abort" handler, is still there.
Here is the print env

Here is the boot log after changing the dtb_mem_addr

Can someone from the Khadas team advice on this asap?

In older kernels I was using 0x1080000, but since 5.2-ish (and using booti) I had to change the load address to 0x1980000 for both GX and G12 hardware. That works for me™

Do you mean the dtb_mem_addr or kernel_addr or env_addr or initrd_addr?
As I just tried with dtb_mem_addr "0x1980000" and facing the same issue.

Update: I tried changing all the addr to "0x1980000" but still it fails.

I might be confusing the things that i’ve worked around … i’m a u-boot novice :slight_smile:

reading Image
27625984 bytes read in 2405 ms (11 MiB/s)

^ but I believe the other time I’ve seen a “Synchronous abort” message was semi-recent poking around on a Realtek SoC board. The godawful Realtek BSP u-boot has a hard limit of 25MB kernel size set (in too many places to exorcsie) and I was seeing boot failures until I set “uImage.lzo” which compressed the kernel file to about ~8MB in size, and since 8 < 25 it started to boot.

Thanks for the reply.

I tried with Image.gz which is around 10MB and it end up with this error.

## Executing script at 01020000
reading Image.gz
11140067 bytes read in 992 ms (10.7 MiB/s)
reading uInitrd
7467479 bytes read in 681 ms (10.5 MiB/s)
reading uEnv.ini
222 bytes read in 27 ms (7.8 KiB/s)
reading /dtbs/amlogic/meson-gxl-s905x-khadas-vim.dtb
36666 bytes read in 43 ms (832 KiB/s)
Bad Linux ARM64 Image magic!
** Bad device usb 1 **
** Bad device usb 2 **
** Bad device usb 3 **

Are you using the old packaged kernel (uImage) format “bootm” :slight_smile:

No we’re using booti

Here is the link for Vim3 which worked but the same didn’t work for Vim1