Linux Kernel build for VIM3


I am trying to get started with Vim3 a311d (V12).
I downloaded VIM3_Ubuntu-server-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530, flashed into an SDCARD and everything works. I can boot from that SDCARD.
But when I try to build my own kernel and replace into the SDCARD, VIM3 fails to boot and boots from internal emmc.
Build steps:

git clone torvalds linux
git checkout origin master
export ARCH=arm64
export CROSS_COMPILE=aarch64-linux-gnu- #gcc-linaro-7.5.0-2019.12-x86_64_aarch64-linux-gnu
make defconfig
make Image dtbs modules

scp arch/arm64/boot/Image root@vim3:/boot/zImage
scp arch/arm64/boot/dts/amlogic/meson-g12b-a311d-khadas-vim3.dtb root@vim3:/boot/dtb.img
scp -r ./modules_install/lib/modules/5.9.0-rc6+ root@vim3:/lib/modules

My uboot env: pastebin RqzJHny8
My kernel config: pastebin WiYUQYTm
My uboot boot log: pastebin dsuWVXNy

There is anything especial in Vim3 that I not doing?
I should only replace kernel and dtb image, copy the modules and the board should into the new kernel using the SDCARD.
I cant see why it would fail on booting from the SDCARD.

Any help is appreciated.

1 Like

erasing emmc from linux did not solve : dd if=/dev/zero of=/dev/bootloader
erasing from uboot did solve “store init 3”

@lucastanure The Fenix repository has the option to compile the mainline code, you can make your changes on the basis of fenix

Hello @lucastanure ,
Thank you for your post. Have you tried suspend/resume on this kernel?
5.7-rc7 suspend ok but no resume, the board hangs

@jaferali75 Sorry, I haven’t tried it on the 5.7 kernel …

@Frank have you succeeded in upgrading to kernel 5.9 ? What magic step that help doing so.