Linux Kernel 4.19 & Kodi Compiling error

3h

Spikerguy:

Where can I find the kernel 4.9 and kodi source code used for this build?

u-boot: https://github.com/khadas/u-boot/tree/khadas-vims-v2015.01
linux: https://github.com/khadas/linux/tree/khadas-vims-4.9.y
kodi: https://github.com/numbqq/xbmc/commits/amlogic-4.9-18.3

Continuing from the Ubuntu Thread.

I tried compiling this branch with the config file I found on the img.
File name: config-4.9.190

I am getting some error

  from ./arch/arm64/include/asm/bug.h:67,
                 from ./include/linux/bug.h:4,
                 from ./include/linux/mmdebug.h:4,
                 from ./include/linux/mm.h:8,
                 from mm/vmscan.c:16:
./include/linux/compiler.h:253:26: error: array subscript 26 is outside array bounds of ‘atomic_long_t[26]’ {aka ‘struct <anonymous>[26]’} [-Werror=array-bounds]
  253 |  case 8: *(__u64 *)res = *(volatile __u64 *)p; break;  \
      |                          ^~~~~~~~~~~~~~~~~~~~
./include/linux/compiler.h:264:2: note: in expansion of macro ‘__READ_ONCE_SIZE’
  264 |  __READ_ONCE_SIZE;
      |  ^~~~~~~~~~~~~~~~
In file included from ./include/linux/mm.h:1023,
                 from mm/vmscan.c:16:
./include/linux/vmstat.h:113:22: note: while referencing ‘vm_node_stat’
  113 | extern atomic_long_t vm_node_stat[NR_VM_NODE_STAT_ITEMS];
      |                      ^~~~~~~~~~~~
cc1: all warnings being treated as errors
  CC      fs/read_write.o
make[1]: *** [scripts/Makefile.build:334: mm/vmscan.o] Error 1
make[1]: *** Waiting for unfinished jobs....
  CC      fs/file_table.o
  CC      fs/super.o
make: *** [Makefile:1105: mm] Error 2
make: *** Waiting for unfinished jobs....
  CC      fs/char_dev.o
  CC      fs/stat.o
  CC      kernel/kmod.o
  CC      fs/exec.o

Also tried to compile kodi from your branch and getting this error
Can someone advice on this ?

Are you build on the VIM1? I usually build with fenix.

1 Like

Yes VIm1 and I found the config in the img you provided for 4.9 usb. As the link you provided for the config is too small and need alot of manual input.