LibreELEC for the VIM2


#21

I can confirm that the system works using @kszaq last build and @balbes150 dtb file. You are on the right path!

Thanks!


#22

Found one bug. If used in eMMC firmware with Nougat and DualOS (they have a close u-boot), LE starts and runs. If you use the firmware in the eMMC with Ubuntu (this firmware version ubuntu of u-boot), LE runs to the point of not including GUI KODI and fixate on it (i.e. kernel normally starts, shows the splash screen and then LE does not run). There is a constant appeal to the media and the entry of many crash logs (I am no expert on KODI and not see it as obvious errors). In my opinion, there is a clear relationship with some of the features in u-boot.
Question to @numbqq. U-boot (branch of ubuntu) made some significant changes from the code of u-boot branches nougat\multios ?


#23

Hi balbes150,

Ubuntu u-boot branch is different from Nougat and DualOS. Ubuntu u-boot is from Amlogic Buildroot-openlinux-20170814.

Thanks.


#24

First post updated with links to working LE build for the VIM2. :slight_smile:


#25

Hello and thanks for the effort.

I would like to run LibreELEC directly from eMMC and not from SD card, is that possible?

So I want only LibreELEC, no Android on the VIM2.


#26

@mrboki I have not tested it yet but you can try to run installtointernal command over SSH. I will try to provide a “supported” way soon.


#27

I also found this from you which explains a lot I guess: https://forum.libreelec.tv/thread/5556-howto-faq-install-community-builds-on-s905-s905x-s912-device/


#28

@kszaq

Model: Khadas VIM2 Pro v. 1.2
Device tree: https://sx05.eu/s912/8.2/device_trees/1Gbit_Ethernet/gxm_q200_3g.dtb
Image: LibreELEC-s912.arm-8.2-8.1.10.img.gz from here:
https://forum.libreelec.tv/thread/5848-8-1-10-libreelec-8-2-for-s912/
Running from: mSDHC-card

Hi!

Sorry don’t know if I should post this here or in the LibreELEC thread here:


Update: Posted on both.

I have problems connecting through my NAS using SMB, I can view and map the drive just fine on Windows 10 / Ubuntu 16.04 and I’ve checked the NAS SMB settings and they are: Max SMB v3, Enable Local Master Browsing. Both are in the same workgroup. I’ve got a user setup on my NAS with the necessary rights (i.e. “Read”) to the folder.

I know that network browsing no longer works for SMB:
https://libreelec.tv/2017/09/libreelec-krypton-v8-1-2-beta/

I was able to browse my share (it lists the folders subdirs) when entering it a “Network Location”:
smb://mynasip/folder/subfolder/
but when trying to add it as a source for ex. Movies I get “File exists” and then an error that LibreELEC can’t open a connection to the share.

When using “Zeroconf browser” I am able to view my NAS and its root-folder but not any subfolders, I get “File exists” again.

My log:
http://sprunge.us/NaaH
where I’m guessing the relevant part is:

21:47:20.666 T:4097523712 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://192.168.10.249/media/movies’
unix_err:‘11’ error : ‘File exists’

Would be grateful for help / TheSwede86


#29

Hi @kszaq,

Can the GPIO ports be used with the LibreElec OS?

Thanks!


#30

@jpataias Honestly I haven’t used the GPIOs but I can’t see no reason why they shouldn’t work. Please try and let us know - if there’s anything missing to support them I can try to add what’s missing.


#31

Hi
Where to find the remote.conf for VTV remote control?


#33

Hi All. First of all thank you for your work @kszaq. I think there is a problem with the DTV extension board in libreelec. Although everything seems to be working ok and I can see my tv adapters in the TV Adapters inside tvheadend, I can’t watch any sat channel with it and if I do a scan every mux fails.

If I test with a external sat->Iptv board, than everything works perfect using vim2 and libreelec, but not with the vim2 tv extension board.

Could someone confirm this? @kszaq have you run some tests using sat in tvheadend?

This is the same problem reported here by other user: https://forum.libreelec.tv/thread/10649-khadas-vim2-and-dtv-board/#post76799

Regards


#34

Hi, @Rashii.
I have same problem.


#35

Could someone attach this file:

“Are you able to send me dbt.img from android? You can find it in android upgrade image or submit ssh command:dd if=/dev/dtb of=/storage/dtb-kvim2.img bs=1k count=256”

in this post: https://forum.libreelec.tv/thread/10649-khadas-vim2-and-dtv-board/#post76826

Regards


#36

Hi, @Rashii.
Upload to libreelec forum also.

vim2-dtb.img


#37

Thank you mate.

Regards.


#38

So, Got my VIM2 and VTV board.
I started out by burning the Android VTV build to the VIM2 and got the VTV program to recognize the terrestrial channels - but it failed to load any sat channels despite finding the muxes, seems this is a common issue which I am not certain there is a solution for yet. However I have just realised that the Android version has no native TVHeadend Server support which is what I need for my home setup.

So I always intended to run LibreELEC anyway and I managed to get LibreELEC-S912.arm.8.2.8.10.img to run - but the version of the dtb I copied to it allowed it to run - but would not recognise either the remote control or find any services for the recognised Sat and DVB-T muxes. I tried changing out the dtb.img for the vim2-dtb.img listed just above - but this stops the boot at the Khadas splash screen.

So at this moment in time neither the Android or the Libreelec builds support the dvb-s function and the libreelec doesn’t support the DVB-T function. Fairly poor show for a product claiming so much.

I await for someone to offer advise or resolve these deep bugs - but reading the thread over at the Libreelec forum it seems there maybe some fundamental issues with the firmware which may not be easy to resolve.

Shoog


#39

Status update,
I decided to follow the advice in the Libreelec threat and try the 8.90 build. Couldn’t get it to boot at all.
Tried it with two different dtb.img (one of them had worked with the 8.2.8 build) and without a dtb.img at all (assuming that would for it to use the Android dtb.img.
Result - nothing !

So it seems we are dangling without a huge amount of hope that anyone is working to resolve this. Very disappointed.

It seems that the issues are very serious and not easily resolved as Stephan describes here:

“Libreelec and VIM2 is clear.
About the vTV HAT, there is no working open source linux drivers at the moment and they can’t be compiled as well if you are not a C+ guru having the vendor source :slight_smile: This HAT and all boards on this chipset can be used only with Android. I make an “investigation” and the problem is much more complicated than just to compile some drivers from available source even it is sent by the vendor itself. Don’t push kszaq to help, because he can’t! Even with compiled drivers this board not work (tested) in linux, because they don’t work. The source spinning around is not the correct one! linux drivers are proprietary peace of software used in commercial linux based STBs. No drivers, no TV. I hope that soon, the chipset vendor will open their drivers, otherwise somebody have to write drivers and not to compile them.”

So here is the next question, I tried the V171024 VTV build and the DVB-S didn’t work so is there a working version of Android with functional DVB-S support, because without it this is gross misrepresentation of the product.

Shoog

Update: Went back and tried the V170930 build of the Android. Scanned for DVB-S first and then attempted to scan DVB-T. Turns out this card is one or the other and doesn’t allow switching between formats (in Android at least). Got all the Sat channels I would expect and performance is good and snappy.


#40

Dear all

please check below dts info that should be useful for embed VTV in LibreElec.

image
image


#41

@kszaq Thanks for your hard work. I have a few questions for you.

  1. Is the first post still the recommended way of installing LibreELEC for the VIM2?
  2. Is it possible to install LE on internal eMMC? If so, what are the advantages if any?
  3. I went to this address to get the latest build: https://forum.libreelec.tv/thread/5848-8-2-2-3-libreelec-8-2-for-s912/ However, it says that this build is discontinued. Does this mean we should be using this: [https://forum.libreelec.tv/thread/10301-8-90-4-libreelec-9-0-alpha-for-s905-s912-devices/]

Thanks again for your help!