Krescue - take full control of your VIM device! easy way to install ANY OS! + back/restore your system

Well I initially thought that Krescue no longer booted from SD but it seems that might be down to the VIM3 Pro doesn’t like the brand I use. After discovering that I can boot Krescue from a thumb drive however, it seems that the images available haven’t REALLY advanced much and so the whole point of the thing seems to be going to waste. The ATV image only accepts a WiFi connection (completely disregarding my 1GB LAN . Not too sure of the logic behind that? So all in all, it still appears to be a great idea that is riddled with bugs. Fortunately it’s not the ONLY way to load images :smiley: :+1:

Got the same problem with the VIM3_Pie_V210908 image. Seems it might actually be an issue with the image itself as the same image that you burn with AML image brner also has the problem. I guess the point is, you guys should be testing these images before you put them out there to stuff up users’ setups :wink:

i still cant clear understand your real problem ?
android images ? or krescue ?

He is trying to tell us that he cannot get the Lan to work.


I will be flashing android again on my vim3 and will test is lan works.

It’s better to note down the bugs and issues in pointers and use simple English for everyone to understand the message you’re trying to convey :wink:
English is (not) everyone’s first language.
Please let us about the other bugs that are present.


I doubt that or there would be no confusion, I AM
English :wink: :rofl:

  1. Krescue just system which can install other system, and for this situation android content will be same doesn’t matter it was written by krescue or by other method
  2. if u have problem with android please submit this issue to android thread

It’s all good. I was curious to have a look at the Android 12 preview. It didn’t work and the latest “stable” Android image (krescue and Amlogic USB Burner versions) presented an issue with Ethernet LAN. Doesn’t matter as I rarely use Android, and every previous backup I made restores perfectly, without any issues. Have a look (or don’t), fix the issues (or don’t). Just reporting what I found :+1:

He is trying to say that krescue is just a flashing and rescue tool.

The issues you’re facing is for images you tried and those issues needs to be reporting on their respective threads.

Example Android Pie is maintained by khadas so look for android pie thread and report it there.

I think ATV is maintain by superceleron as community developer and his thread is different.

So yea you’re reporting the issues on the wrong thread.

Ah! OK, duly noted :+1:

That makes sense now :wink:

1 Like

Hello All,…

"I read a lot of it, but I didn’t have the courage to read all of your 650 posts in this topic…
From all that I have been able to read I have not found any trace of the subject of the following question…"

For security reasons, on my network I am operating in DHCP with address reservation, i.e. no device can connect if I have not previously entered its M@C address in DHCP.

I have no IP delivery address problems when I boot with the VIM with Android image embeded because Eth and Wifi M@C addresses are reserved in the DHCP.

The problem comes when I uses KRescue…

Everytime new KRescue SD-card comes with another M@C address than the VIM hardware M@C addresses !
That’s bores me because everytimes (I mean everytime I burn another new KRescue SD-Card) I have to enter the new KRescue M@C address so that Krescue is authorized to connect to the network.

From where come Eth and Wifi KRescue M@C addresses ? (randomly generated ?)
Why KRescue don’t uses VIM own Eth or Wifi hardware M@C addresses ?

Thanks in advance,

yes its possible for some cases for some boards

please provide more information about this issue !! board model ? which os already installed on emmc ? uboot version ? maybe full boot log from uart console? and we can improve and fix it for next Krescue update

PS: but any way every time u can get access by krescue.local domain

Hello @hyphop,…

Thanks for replying and I take advantage of it to thank you for all the great job you’re doing on this “Swiss knife” KRescue and KRescue OSes images upgrades - Great Job Man ! - :wink:

Sorry to late responding but I had to complete my investigations…

In fact, I’ve got 3 VIMs on my network, two VIM2, v1.2 and v1.4 and one VIM3 v1.2.
Both VIM2 are KRescue ANDROID v7.1.2 NOUGAT EMMC embeded.
VIM3 is ANDROID 9 PIE EMMC embeded.

I have permanantly VIM2 KRescue SD-Card plugged-in, more convenient for regularly EMMC > SD-Card saving dumps :wink: … Unfortunatly, VIM3 always boots on VIM3 KRescue when SD-Card is in it’s slot, I don’t know why, I tried to modify it with KBI configuration, but it still boot on VIM3 KRescue - to use VIM3 with ANDROID 9 PIE EMMC embeded, I have no other choice to plug-out VIM3 KRescue SD-Card :confused:

Regarding the VIMs KRescue M@C addresses “problem”…

VIM2 :
What I can say is that all two VIM2 with the same KRescue SD-Cards acts the same way whether in VIM2 v1.2 or v1.4 they all two boot with random NON VIM2 hardware M@C address, we can boot as many times as we want, at each new boot a new random NON VIM2 hardware M@C address appears !

To confirm the phenomenon, I’ve burnt 3 differents VIM2 KRescue SD-Cards and tried them 3 times in VIM2 v1.2 and v1.4. At each time a new random NON VIM2 hardware M@C address appears !
So, we can say that the phenomenon is VIM type, VIM version and EMMC embeded OSes independent.

VIM3 :
Regarding VIM3 KRescue SD-Cards, the problem isn’t the same…
As for VIM2 I’ve burnt 3 differents VIM3 KRescue SD-Cards.

At every boot VIM3 KRescue SD-Cards always presents the same fixed NON VIM3 hardware M@C address, we can boot as many times as we want, at each new boot, the same fixed NON VIM3 hardware M@C address appears.

U-Boot : (All VIMs same U-Boot version)
VIM2.V12.3G.8C.emmc.29GB, VIM2.V14.3G.8C.emmc.58GB and VIM3.V12.2G.6C.emmc.29G :
FILE : or
UBOOT_VER: 2021.07+

Bootlog from UART console :
You have to wait a little more time for me to figure-out how to do it :wink:

tnx for all detail its already clear for me - i will recheck again and try to fix all mac problems with next Krescue update

1 Like

Hello All,…


I have just finished to perform Bootlog dmesg from UART console.
I’ve got 3 dumps from VIM2 v1.2 and 3 from VIM3 v1.2.

Because of my VIMs IDs I’m not disposed to publish them down here.

Personnaly I took a glance to them and I’ve noticed some differences between VIM2 and VIM3 logs :wink:

How can I send you these 6 files ? Forum MP do not accept attached files :confused:


Hello All,…

(Wish you a best year than the last one !..)

@hyphop any news about a VIM2 KRescue update with a fix of random to fixed generated M@C address ?

tnx ! yes will be fixed later …

Thank’s in advance to inform us when the update will be online :slight_smile:

i have check VIM2 with latest Krescue already! i don’t have this problem .
both mainline uboot and Krescue mainline linux used same static mac address

if u still have this problem please provide more detail


Inside latest Krescue, Online script install for armbian and Altlinux ends with “error 1” . Manjaro and Fedora install ok but slow speed.

Can you please check Armbian and Altlinux scripts? Thanks

Ok i think the problem is the script of Alt Linux wants a tar.xz file but that actual location has img.xz file…. Can you fix that? Or maybe I’m looking at wrong thing?

big tnx for reply i will check it very soon

1 Like