Krescue - take full control of your VIM device! easy way to install ANY OS! + back/restore your system

Your Krescue CoreELEC images introduce different Boot Labels.



So Official CoreELEC updates will Fail.

Error in mount_flash: mount_common: Could not mount LABEL=CE_MMC
Error in mount_sysroot: mount_common: Could not mount /flash/SYSTEM
Error in mount_storage: mount_common: Could not mount LABEL=CE_STORAGE_MMC
mount: mounting /flash on /sysroot/flash failed: No such file or directory
mount: mounting /storage on /sysroot/storage failed: No such file or directory
Error in prepare_sysroot: final_check: Could not find systemd!


OK! i will check whata can i do;) for solve this stupid update behavior :wink:
tnx for response !

PS: plz get more info about image name link and board version

All nightly images for Official CoreELEC are

Nightly Forum is HERE
It’s happening to Vim3 and Vim3L hardware.
I haven’t picked it up because i have been using official CoreELEC images via SD Card
and SuperCeleron ATV Internal eMMC .
Members on Khadas forum and our forum are now poping up with this issue.

To repair and install CoreELEC Official

1 Like

i have VIM3 + M2X Extension Board with SSD and 4g module installed,

I installed latest ANDROID PIE
, seems the data(sim) and gps dont work.

how can i fix this, i go to settings and location and try to turn on GPS location but it wont let me.

the 4G led light on the M2X is on but i still cant use 4g nor gps

Your Krescue CoreELEC images introduce different Boot Labels.

I can confirm this behavior on VIM3 Pro.
Posted question about this on CE forum.
CE was installed with krescue VIM3x image from 2019-12-28, and is broken since CE nightly update 20200228.
Clean install with krescue fails to update to latest nightly, same as previously working install updated on demand every time.

There are Android versions from SC that may or may not help.

[ROM] SC VIM3 Pie ATV Debug/User builds v2 20200117

all questions about android to android thread plz - not there !

1 Like

Hello @hyphop

Seems the krescue for VIM3 the ethernet not work?

i have seen sometimes some strange behavior with Ethernet
its problem for all mainline Kernel on VIM3

i think need more testing!

  1. board booted from emmc? and which uboot version ?
  2. clear emmc boot ! and try start krescue fully from sd and check what happens with ethernet


can you add root?

not at the address, Terry does the firmware, and yes, there has been a root update for a long time

the last time i used fenix, it was still not able to produce mainline kernel debian for emmc, and your khadas recue initiative was our only solution to get mainline kernel install to emmc and booting from emmc, please push harder fenix to become compatible with mainline linux debian kresq :sob:

i have made this one (like a fork) already but in test mode yet (after testing it will be integrated to master branch )

git clone
cd fenix
git checkout hyphop
../scripts/ [VIM1] [VIM2] [VIM3] [VIM3L]

NOTE: last script generate raw and compressed image which suitable write both to EMMC same as SD

NOTE: mainline uboot + mainline kernel + debian 10 buster base

PS: after complete testing we will make announce about new debian images



DOWNLOAD uboot files for each VIMx devices

1 Like

This looks good. So I can just flash this on the SDcard while emmc have legacy uboot, will that be fine ? or this should be on the eMMC ?

  1. can write it to SD/eMMC
  2. VIM3 VIM3L always start from emmc if uboot presented on emmc and sd uboot was ignored
  3. if u have legacy uboot on emmc - u will have same problem with GREEN screen

That means this will not help those you want to keep the android on EMMC and use Linux on SD :frowning:

i still not find elegant universal solution for multiboot - but i try :wink:

  • u can patch your kernel for usage with legacy uboot

We cannot patch it for every use case. So Instead we will just wait for a fixed solution to follow.

at this moment i think krescue installation to emmc its best choice

because if u try to boot somthing from sd u can always depend from emmc uboot

1 Like