Krescue not working or booting

Why ?, Is it due to less power or something ?

I suspect that you did not correctly write Krescue to sd, is this possible?

Could be a very possible reason, Reflashing it should solve the problem…

try recording a Krescue image with Rufus

It does not depend on the software utilized for burning, but moreover verifying that the image was burned succesfully, For me I believe that Win32 diskimager is the best software, providing, Image verification, Image burning and Image backup tools…

I read that when board is powered by PC, it may interfere with boot due to update mode…

yes, it’s better to exclude such things, I always power from the power supply

Oh I see, I am not sure it is even safe to power the board from a PC, except upgrade mode and doing things like ADB, you can’t do much…

I agree that there is something wrong with the CURRENT krescue image for VIM3L.
I have verified with multiple cards and readers, and AFTER I get past fussy-cards etc, it ALWAYS comes back to a kernel panic/dump. (see attached images, sorry about the quality … let me know if you need better!)

This wouldn’t be a such a problem, I guess, if any of the other instructions for writing to eMMC worked!
eg: the ONLY other image I can do anything with is the EMMC image of Ubuntu, which I can burn via USB_Burn_Tool_V2.2.0 running in a Win7 virtual machine … an AWFUL solution.

My aim is to have a situation where I can use:

  1. Access Point
  2. Quectel EM06-A
  3. Kodi
  4. M.2 Storage.

Unfortunately, although I could get the Quectel card to work under (preinstalled) CoreElec, I was unable to convince it to enable the Access Point.
My subsequent theory was that I’d be able to achieve my goal with Ubuntu … but the video playback is unusable.
So, my current attempts revolve around attempting to have Ubuntu (or better, OpenWRT) for routing / file-sharing in the car, and then use CoreElec on SD on location … but I can’t even get close to testing this without krescue working, it seems (even if SD-booting is possible while there’s an operational bootloader on eMMC).

Also note that virtually none of the instructions for clearing eMMC seem to work. I’ve ended up pulling the cord at 15% of the burn as a last result.

Any ideas?

Single-image limit for new users, huh?
Here’s the screen before the dump above

@hyphop can you take a look here, it seems that something is wrong mate…

Are you sure you grabbed the correct version? I see references to the VIM3, yours is VIM3L.
Of course that may be normal. I don’t have the VIM3L to check it.

check vim3 or vim3 L and try another SD card

Just for giggles, I’ve also tried moving/copying meson-sm1-khadas-vim3l.dtb into various directories, in an attempt to get past the FDT_ERR_BADPATH, but none seem to have made a difference.

I DEFINITELY downloaded VIM3L. I even tried downloading from various directories, and they all have matching md5sums (880315ce7bb19edef4bdb51e142e0333), which differs to the VIM3 image (2aefeb953fba4150d36c7e6f1f30931d).

I have DEFINITELY tried various SD cards, both in quality and size.

fwiw: I am not new to this kind of game, having founded the h2200-port of in about 2004-ish, and authored Ramdisk-Rescue … which I suspect none of you will remember!

please check again according to the instructions!

It was not my intention to insinuate anything to the contrary.
When I reply I have no idea of a user’s skill level, I tend to oversimplify by default. :smile:

1 Like

I like it, like that…

1 Like

you may take the bragging rights mate, but not everyone is a pro here :sweat_smile:

Me too, and in my case, simplicity meshes well with my actual skill level. :laughing: